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1 Introduction 

Direct memory access (DMA) controllers transfer data between peripherals and memory without CPU intervention. 
The DMA controller (DMAC) in PSoC

®
 3 and PSoC 5LP features 24 channels and 128 transaction descriptors (TDs), 

making it very versatile for a wide variety of applications. PSoC CreatorÊ, the development environment for PSoC, 
has tools including a DMA wizard and component APIs that make it easy to design complex DMA functions. 

This application note teaches you advanced methods to get maximum performance from the PSoC DMAC. The 
topics covered include DMA timing, DMA channel priority handling, multi-byte data alignment, and methods to modify 
a TD dynamically.  

This application note assumes that you are already familiar with the topics discussed in the basic DMA application 
note, AN52705 ï Getting Started with DMA. It also assumes that you are familiar with developing applications using 
PSoC Creator for PSoC 3 or PSoC 5LP. If you are new to these products, you can find introductions in AN54181 ï 
Getting Started with PSoC 3 and AN77759 ï Getting Started with PSoC 5LP. If you are new to PSoC Creator, see 
the PSoC Creator home page. 

http://www.cypress.com/?rID=37793
http://www.cypress.com/?rID=44335
http://www.cypress.com/?rID=37793
http://www.cypress.com/?rID=37793
http://www.cypress.com/?rID=37793
http://www.cypress.com/?rID=39157
http://www.cypress.com/?rID=39157
http://www.cypress.com/?rID=60890
http://www.cypress.com/?id=2494
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2 PSoC Resources 

Cypress provides a wealth of data at www.cypress.com to help you to select the right PSoC device for your design, 
and to help you to quickly and effectively integrate the device into your design. For a comprehensive list of resources, 
see  KBA86521, How to Design with PSoC 3, PSoC 4, and PSoC 5LP. The following is an abbreviated list for PSoC 
4: 

¶ Overview: PSoC Portfolio, PSoC Roadmap 

¶ Product Selectors: PSoC 1, PSoC 3, 
PSoC 4, or PSoC 5LP. In addition, PSoC 
Creator includes a device selection tool. 

¶ Datasheets: Describe and provide electrical 
specifications for the PSoC 4000, PSoC 4100, 
and PSoC 4200, PSoC 4xx7 BLE, PSoC 
4200-M device families 

¶ CapSense Design Guide: Learn how to 
design capacitive touch-sensing applications 
with the PSoC 4 family of devices. 

¶ Application Notes and Code Examples: 
Cover a broad range of topics, from basic to 
advanced level. Many of the application notes 
include code examples. PSoC Creator 
provides additional code examples ï see 
Code Examples. 

¶ Technical Reference Manuals (TRM): 
Provide detailed descriptions of the 
architecture and registers in each PSoC 4 
device family. 

¶ Development Kits: 

¶ CY8CKIT-040, CY8CKIT-042, and 
CY8CKIT-044 PSoC 4 Pioneer Kits are 
easy-to-use and inexpensive development 
platforms. These kits include connectors 
for ArduinoÊ compatible shields and 
DigilentÈ PmodÊ daughter cards. 

¶ CY8CKIT-049 is a very low-cost 
prototyping platform for sampling PSoC 4 
devices. 

¶ CY8CKIT-001 is a common development 
platform for all PSoC family devices. 

¶ The MiniProg3 device provides an interface 
for flash programming and debug. 

2.1 PSoC Creator 

PSoC Creator is a free Windows-based Integrated Design Environment (IDE). It enables concurrent hardware and 
firmware design of systems based on PSoC 3, PSoC 4, and PSoC 5LP. See Figure 1 ï with PSoC Creator, you can: 

1. Drag and drop Components to build your 
hardware system design in the main design 
workspace 

2. Codesign your application firmware with the 
PSoC hardware 

3. Configure Components using configuration 
tools 

4. Explore the library of 100+ Components 

5. Review Component datasheets 

http://www.cypress.com/
http://www.cypress.com/?id=4&rID=77024&source=an79953
http://www.cypress.com/psoc
http://www.cypress.com/?rID=86788&source=an79953
http://www.cypress.com/?id=1573&source=an79953
http://www.cypress.com/?id=5041&source=an79953
http://www.cypress.com/?id=4976&source=an79953
http://www.cypress.com/?id=5044&source=an79953
http://www.cypress.com/?rID=94034&source=an79953
http://www.cypress.com/?rID=78805&source=an79953
http://www.cypress.com/?rID=78632&source=an79953
http://www.cypress.com/?rID=99492
http://www.cypress.com/?rID=108039
http://www.cypress.com/?rID=108039
http://www.cypress.com/?rID=78578&source=an79953
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=76&id=4749
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=117&id=4749&applicationID=0&l=0
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=110&id=4749&applicationID=0&l=0
http://www.cypress.com/?rID=94456&source=an79953
http://www.cypress.com/go/cy8ckit-042
http://www.cypress.com/cy8ckit-044
http://www.cypress.com/?rID=92146&source=an79953
http://www.cypress.com/go/cy8ckit-001
http://www.cypress.com/go/cy8ckit-002
http://www.cypress.com/psoccreator/?source=an79953
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Figure 1. PSoC Creator Features 
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2.2 Code Examples 

PSoC Creator includes a large number of code example projects. 
These projects are available from the PSoC Creator Start Page, 
as Figure 2 shows. 

Example projects can speed up your design process by starting 
you off with a complete design, instead of a blank page. The 
example projects also show how PSoC Creator Components can 
be used for various applications. Code examples and datasheets 
are included, as Figure 3 shows. 

In the Find Example Project dialog shown in Figure 3, you have 
several options: 

¶ Filter for examples based on architecture or device family, 
i.e., PSoC 3, PSoC 4 or PSoC 5LP; category; or keyword 

¶ Select from the menu of examples offered based on the Filter 
Options 

¶ Review the datasheet for the selection (on the Documentation 
tab) 

¶ Review the code example for the selection. You can copy and 
paste code from this window to your project, which can help 
speed up code development, or 

¶ Create a new project (and a new workspace if needed) based 
on the selection. This can speed up your design process by 
starting you off with a complete, basic design. You can then 
adapt that design to your application. 

Figure 2. Code Examples in PSoC 
Creator 

 

Figure 3. Code Example Projects, with Sample Code 
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2.3 PSoC Creator Help 

Visit the PSoC Creator home page to download the latest version of PSoC Creator. Then, launch PSoC Creator and 
navigate to the following items: 

¶ Quick Start Guide: Choose Help > Documentation > Quick Start Guide. This guide gives you the basics for 
developing PSoC Creator projects. 

¶ Simple Component example projects: Choose File > Open > Example projects. These example projects 
demonstrate how to configure and use PSoC Creator Components. 

¶ Starter designs: Choose File > New > Project > PSoC 4 Starter Designs. These starter designs demonstrate 
the unique features of PSoC 4. 

¶ System Reference Guide: Choose Help > System Reference > System Reference Guide. This guide lists and 
describes the system functions provided by PSoC Creator. 

¶ Component datasheets: Right-click a Component and select ñOpen Datasheet.ò Visit the PSoC 4 Component 
Datasheets page for a list of all PSoC 4 Component datasheets. 

¶ Document Manager: PSoC Creator provides a document manager to help you to easily find and review 
document resources. To open the document manager, choose the menu item Help > Document Manager. 

2.4 Technical Support 

If you have any questions, our technical support team is happy to assist you. You can create a support request on the 
Cypress Technical Support page. 

If you are in the United States, you can talk to our technical support team by calling our toll-free number: +1-800-541-
4736. Select option 8 at the prompt. 

You can also use the following support resources if you need quick assistance. 

¶ Self-help 

¶ Local Sales Office Locations 

http://www.cypress.com/?id=2494&source=an79953
http://www.cypress.com/?id=4749&rtID=377
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=377&id=4749&source=an79953
http://www.cypress.com/?app=search&searchType=advanced&keyword=&rtID=377&id=4749&source=an79953
https://secure.cypress.com/myaccount/?id=25&techSupport=1&source=an79953
http://www.cypress.com/support
http://www.cypress.com/?id=1062
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3 DMA Considerations 

The DMAC is one of the most useful components in PSoC 3 and PSoC 5LP. However, it also exposes a whole new 
set of design considerations with which you may not be familiar. Here are some points to consider when designing a 
system with DMA. 

3.1 DMA Terms and Definitions 

Following is a list of terms and definitions that are used in this application note. These terms are described in detail in 
AN52705 ï Getting Started with DMA but are included here for clarity. 

Peripheral HUB (PHUB): The PHUB is the central hub that has data buses connected between the CPU, DMAC, 
and on-chip peripherals and memory. 

Spoke: Spokes are data buses that branch out from the PHUB to peripherals. Spoke widths can be 16 or 32 bits; see 
the device datasheet and Technical Reference Manual (TRM) for details. Figure 4 shows the PHUB and spoke 
connections. 

Channel: DMA channels use the PHUB to transfer data. A channel fetches transaction descriptors, accesses the 
PHUB spokes for the source and the destination, and transfers data. 

Transaction descriptor: A TD stores all information required for a data transfer, including the source and destination 
addresses and the number of bytes to transfer. Multiple chained TDs can be allocated to a single DMA channel. 

Figure 4. Peripheral HUB 
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3.2 DMA Timing 

This section describes how to calculate the best-case timing for a DMA channel. Many factors can cause the DMA to 
deviate from this best-case timing; those factors are also discussed here. 

The PSoC DMAC operates at the same frequency as the CPU, which is the bus clock frequency. Most PSoC family 
members run at a bus clock frequency as high as 67 MHz. DMA data transfers are either intra-spoke (within the same 
PHUB spoke) or inter-spoke (between different PHUB spokes). 

For each data transfer, the DMA implements a set of phases, as Figure 5, Figure 6, and Figure 7 show: 

Á DMA request (DRQ) latch phase: It takes one clock cycle for the DMA request to be latched into the DMAC. 

Á Arbitration phase: This phase is used to arbitrate between simultaneous requests from multiple DMA channels. 
One clock cycle is required for this phase. If a channel loses arbitration, it reenters the queue and waits for the 
next arbitration cycle. 

Á Fetch phase: This phase is used fetch the TD and configuration information for the channel. One clock cycle is 
required. 

Á Source engine phase: This phase is used to select the spoke to which the source memory or peripheral is 
connected. If the spoke is being used by another bus master, that is, the CPU, data transfer from the source is 
delayed until the spoke is available. The source engine phase initially consists of a bus control cycle followed by 
a data cycle. Then the control and data cycles are pipelined in parallel. 

Á Destination engine phase: This phase selects the spoke to which the destination peripheral is connected. The 
data collected in the source engine phase is transferred to the destination peripheral as soon as the spoke is 
available. The destination engine phase initially consists of a bus control cycle followed by a data cycle. Then the 
control and data cycles are pipelined in parallel. 

Á Write back phase: In this phase, the TD and DMA channel configurations are updated after the data transfer. 
This phase requires one clock cycle. 

Figure 5 shows a simple state diagram for a DMA transfer. Figure 6 and Figure 7 on page 8 show the actual timing 
for an inter-spoke and an intra-spoke data transfer. 

Figure 5. DMA Data Transfer State Diagram 
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The number of clock cycles required for the source engine and destination engine phases is the same for an inter-
spoke and an intra-spoke data transfer. However, the two phases can happen in parallel for an inter-spoke transfer, 
which usually requires fewer clock cycles. 

Figure 6. Timing Diagram for DMA Inter-Spoke Data Transfer 
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Figure 7. Timing Diagram for DMA Intra-Spoke Data Transfer 
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When calculating DMA timing, start with the ideal conditions, as follows: 

Á Only one DMA channel is active, and there is no arbitration between multiple DMA channels. 

Á There is no arbitration between the DMAC and the CPU. Note that the CPU and the DMAC can access different 
spokes simultaneously. 

Á The source and the destination spokes are available when the transfer is to be done. 

Á The source and destination spoke widths are the same. 

Á The data length is an even multiple of the spoke width, in bytes. 

Á The source and destination start addresses are on a spoke width boundary. 
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The number of bursts required for a DMA transfer N is defined as follows: 

ὔόάὦὩὶ έὪ ὦόὶίὸί ὔ  
 

 
  (1) 

where transfer count and spoke width are in bytes. See AN52705 for details on DMA burst transfers. 

If the ideal conditions are met, the number of clock cycles required for an inter-spoke data transfer is calculated as 
follows: 

C = 1 clock cycle to latch the drq signal  + 

1 clock cycle for arbitration phase  + 

1 clock cycle for fetch phase  + 

(N + 3) clock cycles for source and destination engine phases  + 

1 clock cycle for write back phase 

ὅ  ὔ χ (2) 

 

The number of clock cycles required for an intra-spoke data transfer is calculated as follows: 

C = 1 clock cycle to assert the drq signal  + 

1 clock cycle for arbitration phase  + 

1 clock cycle for fetch phase  + 

(N + 1) clock cycles for source engine phase  + 

(N + 1) clock cycles for destination engine phase  + 

1 clock cycle for write back phase 

ὅ  ςὔ φ (3) 

 

The exact number of clock cycles required for a DMA transaction under non-ideal conditions varies depending on the 
conditions. Use the following tips to calculate the clock cycles required for a non-ideal DMA transaction: 

1. The clock cycle to assert the drq signal is not required for continuous DMA transfers. For example, if the transfer 
length is set to 100 and the request per burst is set to 0 (complete transfer in a single request), the latching of the 
request is required only for the first DMA transfer. 

2. The arbitration between multiple DMA channels takes only one clock cycle. If the DMAC is already performing a 
data transfer, arbitration is performed in parallel with the data transfer, and this clock cycle is hidden. 

3. If the CPU is competing with the DMAC for a spoke, the DMAC must wait until the CPU releases the spoke if the 
CPU is assigned a higher priority than the DMAC. The priority of the CPU over the DMAC is controlled using the 
spk_cpu_pri[6:0] bits in the PHUB_CFG register. See the ñPHUBò section in the PSoC Registers TRM for details. 

4. If the source or destination start address is not on a spoke width boundary, the number of clock cycles required 
for the DMA transfer varies depending upon the spoke width and the addresses. The formulas in Equations (1) 
and (2) for inter-spoke and intra-spoke transfers can also be used in this case, with a change in the value of N as 
calculated by Equation (3). 

If the source and destination widths are 32 bits, N is unchanged if the source and destination addresses are 32-
bit DWORD aligned. N is multiplied by 2 if the source and destination are WORD aligned, and N is multiplied by 3 
if the source and destination are BYTE aligned. See the section Multi-Byte Data Alignment for details. 

5. If endian swapping is enabled for an inter-spoke DMA transaction, the destination transfer cannot occur until the 
last source byte has been put into the DMAC FIFO. The DMAC must write the last source byte to the first location 
of the destination to do the endian swap. The effective value of N in this case is calculated as (N calculated with 
Source spoke width) + (N calculated with Destination spoke width) ï 1. 

6. If the source and destination peripherals have unequal spoke widths, the number of clock cycles required for a 
transfer is governed by the narrower spoke width. In this case, N = (Transfer Count) / (Narrower Spoke Width). 

http://www.cypress.com/?rID=37793
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Table 1 shows the number of clock cycles required for a DMA transfer in different scenarios to transfer N bursts of 
data. 

Table 1. Number of Clock Cycles for DMA Transfer between PSoC Resources 

Use Case Number of Clock Cycles 

Flash to SRAM N + 7 

SRAM to SRAM 2N + 6 

SRAM to peripherals N + 7 

Peripherals to SRAM N + 7 

Peripherals to peripherals 2N + 6 

Appendix C: DMA Channel Arbitration Flow Diagram provides a flow diagram for DMA channel arbitration. 

3.3 DMA Channel Priority Handling 

Each of the 24 DMA channels is assigned a priority value ranging from 0 to 7, with 0 being the highest priority and 7 
being the lowest. Since there are only 8 different priorities and 24 DMA channels, multiple channels may have the 
same priority. 

For channels having the same priority, two methods are used to decide which channel gets priority: 

1. Simple priority: The lowest channel number has a higher priority. This is enabled by default. 

2. Round robin: Round robin priority ensures that all channels get an equal opportunity to access the PHUB. This is 
disabled by default and is set using the API function CyDmaChRoundRobinEnable(). 

For channels with different priorities, two rules are applied to determine which channel gets priority: 

1. Simple priority: The channel with the lowest priority number gets priority. 

2. Grant allocation fairness algorithm: The grant allocation fairness algorithm is designed such that even the lowest 
priority channels get access once in a while. With this method, channels with priorities 0 and 1 always have 100 
percent access and are not interrupted, with the exception that 0 is higher priority than 1. The channels with 
priorities 2 to 7 are given access according to Table 2. 

Table 2. Channel Priority Distribution 

Channel Priority Bandwidth (%) 

2 50 

3 25 

4 12.5 

5 6.25 

6 3 

7 1.5 

 

The grant allocation fairness algorithm is enabled by default. You can disable it by setting the simple priority bit (bit 
23) in the PHUB_CFG register. See the ñPHUBò section of the PSoC 3 Registers TRM and PSoC 5LP Registers TRM 
for details. 

Note that Table 2 applies only if DMA channels with all the priorities are requesting simultaneously. Otherwise, the 
DMA channel with a higher priority is given more access than Table 2 shows. 

Figure 8 shows a channel priority wheel that describes how the next 63 requests are handled if all channels with 
priorities 2 to 7 are requesting simultaneously. 

http://www.cypress.com/?rID=37833
http://www.cypress.com/?rID=73299
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Figure 8. DMA Channel Priority Wheel 
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The bandwidth utilization of the DMA channel can be defined as the number of clock cycles utilized by the DMA 
channel for the data transfer as a percentage of the total number of available clock cycles across sustained DMA 
requests of burst length N. 

For inter-spoke data 
transfers: ὄὡ  

 
ρππ (4) 

For intra-spoke data 
transfers: ὄὡ  

 
ρππ (5) 

 
If a channel with priority 2 to 7 is not requesting, the slots of the missing channel priority are used by the channel with 
the highest priority. In that case, channels with a higher priority get more access than Figure 8 shows. 

3.4 Terminating a TD Chain 

In some cases, a TD must be terminated before data transfer is completed. This is called non-count termination. 
There are three methods to terminate a TD and abort a DMA transaction: 

Á API function call to terminate the current TD [CyDmaChSetRequest(channel, CPU_TERM_TD)] 

Á API function call to terminate the current TD chain [CyDmaChSetRequest(channel, CPU_TERM_CHAIN)] 

Á Hardware trq signal 

Use the API function CyDmaChSetRequest() to terminate either the current TD or the entire TD chain. This API 
function disables the DMA channel and terminates the chain of TDs if the second parameter is set to 
CPU_TERM_CHAIN. This API terminates the current TD but does not disable the DMA channel if the second 
parameter is set to CPU_TERM_TD. 

When one of these methods is used, the DMA channel is reconfigured as if the current transaction has completed 
normally. If enabled, the nrq signal is activated; see the DMA Component datasheet for details. 

Note: The DMA channel completes any ongoing transaction before terminating, so termination may require some 
cycles for the final transaction to be complete. The DMAC may transfer more data bytes before terminating the TD. 
You should be extremely careful while accessing these memory locations after a terminate TD API request as the 
function is not blocking and may return before the data transfer has been actually terminated. 

 

 

http://www.cypress.com/?rID=46450


 
 

  

PSoC
®
 3 and PSoC 5LP Advanced DMA Topics 

 

www.cypress.com Document No. 001-84810 Rev. *C 12 

3.4.1 Using the Hardware trq Signal  

You can also use the hardware signal trq, or termination request. This signal, when asserted during the source 
engine phase of a transaction, stops the DMA transaction. 

This is an effective way to terminate a TD using a hardware signal when the transfer count is set to zero. If the 
transfer count parameter of a TD is set to zero, the TD runs indefinitely unless it is terminated by a non-count 
termination. See Appendix B: Termination Request Signal for an example of how to use the trq signal. 

Note: The trq signal is used only when the DMA is trying to transfer data. A positive edge on this line is ignored at all 
other times. 

4 Multi-Byte Data Alignment 

One feature of the DMAC is that it can transfer more than one byte in a single bus cycle. This allows more efficient 
and faster data transfers. 

The section DMA Timing introduced 
the concept of N: ὔόάὦὩὶ έὪ ὦόὶίὸί ὔ  

 

 
 (6) 

Here are some examples: 

For Transfer Count = 2; Spoke Width = 2: N = 1 

For Transfer Count = 4; Spoke Width = 2: N = 2 

For Transfer Count = 3; Spoke Width = 2: N = 2 (always round up to the next integer) 

For Transfer Count = 4; Spoke Width = 4: N = 1 

All of these calculations assume that the source and destination addresses are aligned. There are three possible 
ways for addresses to be aligned: BYTE, WORD, and DWORD, as Figure 9 shows: 

Á BYTE = All addresses 

Á WORD = Even or 16-bit addresses: 0x00, 0x02, 0x04, 0x06, 0x08, 0x0A, 0x0C, 0x0E, and so on 

Á DWORD = 32-bit addresses: 0x00, 0x04, 0x08, 0x0C, and so on 

Figure 9. Notation to Represent Possible Data Alignments in the Memory 
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To reduce the number of clock cycles needed for a data transfer, align the source and destination addresses with the 
spoke width boundaries. An address is aligned with a 32-bit spoke width boundary if the address is DWORD aligned. 
An address is aligned with a 16-bit wide spoke if the address is WORD aligned. BYTE-aligned addresses are never 
aligned with any spoke width boundary. 

Note: In some cases, if the addresses are not aligned with the spoke width boundaries, the DMAC may fetch 
incorrect data from the source or write incorrect data to the destination address. Appendix D: Misaligned Data 
Transfers details the results of misaligned data transfers. 

You can avoid incorrect data transfers by using one of the following methods: 

1. Enable the increment source address or increment destination address option in the TD configuration. 

2. Force the source and destination addresses to the spoke width boundaries. 

Figure 10 and Figure 11 show WORD-aligned and BYTE-aligned arrangements for 16-bit data, respectively. 
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Figure 10. WORD-Aligned Arrangement of 16-Bit Data 
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Figure 11. BYTE-Aligned Arrangement of 16-Bit Data 

0x00 0x01 0x02 0x03 0x04 0x05 0x06 0x07 0x08 0x09 0x0A 0x0B 0x0C 0x0D 0x0E 0x0F

BYTE BYTE BYTE BYTE BYTE BYTE BYTE BYTE BYTE BYTE BYTE BYTE BYTE BYTE BYTE BYTE

DATA VALUE

 

A data transfer from address location ñnò is carried out in a single clock cycle if the data at the source is aligned with 
the spoke boundary, as Figure 12 shows. When the data is BYTE aligned, data transfer takes two clock cycles, as 
Figure 13 shows. 

Figure 12. Data Transfer of WORD-Aligned 16-Bit Data 
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Figure 13. Data Transfer of BYTE-Aligned 16-Bit Data 
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Figure 14, Figure 15, and Figure 16 show the DWORD-aligned, WORD-aligned, and BYTE-aligned arrangements for 
a 32-bit data transfer, respectively. 

Figure 14. DWORD-Aligned Arrangement of 32-Bit Data 

0x00 0x01 0x02 0x03 0x04 0x05 0x06 0x07 0x08 0x09 0x0A 0x0B 0x0C 0x0D 0x0E 0x0F

DATA VALUE

DWORD DWORD DWORD DWORD
 

Figure 15. WORD-Aligned Arrangement of 32-Bit Data 
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Figure 16. BYTE-Aligned Arrangement of 32-Bit Data 

0x00 0x01 0x02 0x03 0x04 0x05 0x06 0x07 0x08 0x09 0x0A 0x0B 0x0C 0x0D 0x0E 0x0F

BYTE BYTE BYTE BYTE WORD BYTE BYTE BYTE BYTE BYTE BYTE BYTE BYTE BYTE BYTE

DATA VALUE

 

The data transfer from address location ñnò is carried out in a single clock cycle if the data at the source is aligned 
with the spoke boundary, as Figure 17 shows. When the data is WORD aligned, the data transfer takes two clock 
cycles, and when the data is BYTE aligned, data transfer takes three clock cycles, as Figure 18 and Figure 19 show. 

Figure 17. Data Transfer of DWORD-Aligned 32-Bit Data 

Peripheral A 

(32-bit data)

32-bit 

spoke

Bus Clock

DWORD

from address 

0x04

Data Read Cycles 

for Burst = 4

( DWORD Aligned 

Data)

32-bit 

spoke
Peripheral B 

(32-bit data)

 

Figure 18. Data Transfer of WORD-Aligned 32-Bit Data 
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Figure 19. Data Transfer of BYTE-Aligned 32-Bit Data 
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Note: If the transfer count is odd, the number of cycles is different. For example a 3-byte burst on a 32-bit spoke 
takes two clock cycles, even if the addresses are DWORD aligned: one cycle to transfer two bytes, and another to 
transfer the third byte. Also, if increment source and destination address are not enabled in the TD configuration, only 
the first two bytes are transferred. 

For the Keil compiler, use the keyword _at_  to force variables into absolute address locations in SRAM. This 

ensures that variables are aligned with even address boundaries, for example: 

uint 8 myVariable _at_  0x1000;  

Note: Variables forced to absolute memory locations cannot be initialized. 

For the GCC compiler, use the keyword __attribute__  to force variables to 16-bit or 32-bit address boundaries. 

For example: 

uint32  var __attribute__  ((aligned(32)));  
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You can replace the number 32 in the previous format with 16 to align the variables with 16-bit address boundaries. 
You must use the appropriate keywords to align the data with the spoke width boundaries, depending upon your 
compiler. 

4.1.1 Al igning UDBs 

You can do DMA transfers to and from the registers in UDB-based PSoC Creator Components, though enabling the 
increment source or destination address is not always a viable option. To work around this, you may need to force the 
Component to be aligned with an address boundary. You can use PSoC Creator directives to force a UDB-based 
Component to start at a specific address. 

There are as many as 24 UDBs in a PSoC device, and each set of UDB registers has a particular base address. The 
base addresses for the UDBs are provided in the PSoC 3 Registers TRM and PSoC 5LP Registers TRM. The UDBs 
are distributed in the form of two banks and are numbered in a specific fashion, as Figure 20 shows. The dashed line 
represents how UDBs are chained. 

Figure 20. Organization of PSoC UDBs 
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The numbers in blue on the top and left of the diagram are the indices that PSoC Creator uses to address each of the 
UDBs. The numbers inside the squares indicate the UDB number. For example, UDB0 is addressed as U(2,5). To 
find out where PSoC Creator places a Component in the UDB array, follow these steps: 

1. Place a 16-bit UDB-based Counter Component in the TopDesign, as Figure 21 shows, and build the project. 

Figure 21. Counter Component 

 

http://www.cypress.com/?rID=37833
http://www.cypress.com/?rID=73299
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2. Examine the .rpt file to find the location where PSoC Creator has placed the Component, as Figure 22 shows. 

Figure 22. Finding the UDB Location of the Component 

 

Figure 22 shows that PSoC Creator has placed the Component in UDBs U(2,4) and U(3,4) or UDB3 and UDB2. The 
LSB data path of the Component is located in UDB2. In the Registers TRM, the FIFO 0 (F0) address for UDB2 is 
0x6442, which is a WORD-aligned address. Note that the UDB register space is on a 16-bit spoke, and the DMAC 
can transfer two bytes, or one word, in one clock cycle on this spoke. 



 
 

  

PSoC
®
 3 and PSoC 5LP Advanced DMA Topics 

 

www.cypress.com Document No. 001-84810 Rev. *C 17 

If the Component placement was unaligned for some reason, follow these steps to align the counter FIFO 0 
addresses with a word address boundary: 

1. Open the .rpt file and locate the line ñDesign Equations,ò as Figure 23 shows. Expand the list by clicking on the 
[+] symbol left of the line. Locate the line ñDatapath listingò to find the fully elaborated name of the Component. 

Figure 23. Locating the Fully Elaborated Name of the Component 

 

2. Open the .cydwr file, go to the Directives tab, and add a directive using the Add Directive button, as Figure 24 
shows. In the column ñComponent (Signal) Name,ò type the fully elaborated Component name obtained from the 
.rpt file. Select ñForceComponentUDBò as the directive type. Enter the required UDB location as mentioned 
previously. To force the Counter to UDB0, where the FIFO 0 address is 0x6440, which is WORD aligned, enter 
U(2,5). 

Figure 24. Adding the Directive 

 

3. Rebuild the project, and then check the .rpt file again to confirm that the counter was placed in UDB(2,5). 
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5 Writing to Standard Registers and Components 

The DMAC can transfer data to and from almost any memory or register location in PSoC. This includes the memory, 
UDBs, and registers of any PSoC Creator Component. However, the DMA Wizard provided with PSoC Creator 
supports data transfer between only a few Components. 

To use DMA to transfer data between Components that are not supported by the DMA Wizard, you must find the 
addresses of the Components' registers. To do so, use the PSoC register maps in the PSoC 3 Registers TRM and 
PSoC 5LP Registers TRM. 

For example, the following steps show how to transfer a byte of data from a GPIO port to an SRAM location. 

1. Place a Pins Component in the TopDesign and change the number of pins to 8, as Figure 25 shows. Deselect 
the option hardware connection (HW Connection). 

2. Enable the port interrupt control unit (PICU) interrupt, as Figure 26 shows. The PICU interrupt is used to trigger 
the DMA channel to initiate a data transfer. 

Figure 25. Configuring GPIO Pins (Type Tab) 

 

Figure 26. Configuring GPIO Pins (Input Tab) 

 

http://www.cypress.com/?rID=37833
http://www.cypress.com/?rID=73299
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3. Place two DMA Components and a Character LCD Component in the TopDesign. Wire the Components as 
Figure 27 shows. 

Figure 27. Completed TopDesign 

 

4. Assign a suitable port for the GPIO using the .cydwr file. Then, if you selected port 5, for example, locate the 
address of port 5 in the register map, as Figure 28 shows. 

Figure 28. Locate the Address From the Register Map 

 

5. You can use either the absolute address (0x5151) or the alias (Input_Signal_PS) in your code to address the port 
pin state register. 

You can find out the alias names for the Component registers from the ñ.hò generated file of the Component. 
These files are automatically generated by PSoC Creator when you build the project. In this case, the alias name 
Input_Signal_PS is defined in the file Input_Signal.h. 
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6. The PICU interrupt must be cleared each time it is triggered. All interrupts from the port are masked until the 
interrupt is cleared. The PICU interrupt is cleared by reading the interrupt status register of the port. 

7. This example uses two DMA channels: one to transfer the GPIO input value to SRAM and the other to clear the 
PICU interrupt. 

8. Open the DMA Wizard from the PSoC Creator menu via Tools > DMA Wizard, as Figure 29 shows. 

Figure 29. Configure DMA_1 

 










































