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Copyrights 

© Cypress Semiconductor Corporation, 2016. This document is the property of Cypress Semiconductor Corporation and its 
subsidiaries, including Spansion LLC (ñCypressò).  This document, including any software or firmware included or referenced 
in this document (ñSoftwareò), is owned by Cypress under the intellectual property laws and treaties of the United States and 
other countries worldwide.  Cypress reserves all rights under such laws and treaties and does not, except as specifically 
stated in this paragraph, grant any license under its patents, copyrights, trademarks, or other intellectual property rights.  If 
the Software is not accompanied by a license agreement and you do not otherwise have a written agreement with Cypress 
governing the use of the Software, then Cypress hereby grants you a personal, non-exclusive, nontransferable license 
(without the right to sublicense) (1) under its copyright rights in the Software (a) for Software provided in source code form, 
to modify and reproduce the Software solely for use with Cypress hardware products, only internally within your organization, 
and (b) to distribute the Software in binary code form externally to end users (either directly or indirectly through resellers and 
distributors), solely for use on Cypress hardware product units, and (2) under those claims of Cypressôs patents that are 
infringed by the Software (as provided by Cypress, unmodified) to make, use, distribute, and import the Software solely for 
use with Cypress hardware products.  Any other use, reproduction, modification, translation, or compilation of the Software is 
prohibited. 

TO THE EXTENT PERMITTED BY APPLICABLE LAW, CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR 
IMPLIED, WITH REGARD TO THIS DOCUMENT OR ANY SOFTWARE OR ACCOMPANYING HARDWARE, INCLUDING, 
BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE. To the extent permitted by applicable law, Cypress reserves the right to make changes to this document without 
further notice. Cypress does not assume any liability arising out of the application or use of any product or circuit described 
in this document.  Any information provided in this document, including any sample design information or programming code, 
is provided only for reference purposes.  It is the responsibility of the user of this document to properly design, program, and 
test the functionality and safety of any application made of this information and any resulting product.  Cypress products are 
not designed, intended, or authorized for use as critical components in systems designed or intended for the operation of 
weapons, weapons systems, nuclear installations, life-support devices or systems, other medical devices or systems 
(including resuscitation equipment and surgical implants), pollution control or hazardous substances management, or other 
uses where the failure of the device or system could cause personal injury, death, or property damage (ñUnintended Usesò).  
A critical component is any component of a device or system whose failure to perform can be reasonably expected to cause 
the failure of the device or system, or to affect its safety or effectiveness.  Cypress is not liable, in whole or in part, and you 
shall and hereby do release Cypress from any claim, damage, or other liability arising from or related to all Unintended Uses 
of Cypress products.  You shall indemnify and hold Cypress harmless from and against all claims, costs, damages, and other 
liabilities, including claims for personal injury or death, arising from or related to any Unintended Uses of Cypress products. 

Cypress, the Cypress logo, Spansion, the Spansion logo, and combinations thereof, WICED, PSoC, CapSense, EZ-USB,  
F-RAM, and Traveo are trademarks or registered trademarks of Cypress in the United States and other countries.  For a more 
complete list of Cypress trademarks, visit cypress.com.  Other names and brands may be claimed as property of their 
respective owners. 
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Safety Information 

  

The CY3676 Evaluation Kit is intended for use as an evaluation platform for hardware or software in a laboratory environment. 
The board is an open system design, which does not include a shielded enclosure, so the board may cause interference to 
other electrical or electronic devices in close proximity. In a domestic environment, this product may cause radio interference. 
In such cases, the user may be required to take adequate preventive measures. Also, this board should not be used near any 
medical equipment or RF devices. 

Attaching additional wiring to this product or modifying the product operation from the factory default may affect its 
performance and cause interference with other apparatus in the immediate vicinity. If such interference is detected, suitable 
mitigating measures should be taken. 

 

The CY3676 Evaluation Kit contains electrostatic discharge (ESD)-sensitive devices. Electrostatic 
charges readily accumulate on the human body and any equipment, and can discharge without detection. 
Permanent damage may occur on devices subjected to high-energy discharges. Proper ESD precautions 
are recommended to avoid performance degradation or loss of functionality. Store unused CY3676 
Evaluation Kit boards in the protective shipping package. 

 

General Safety Instructions 

ESD Protection  

ESD can damage boards and associated components. Cypress recommends that the user perform procedures only at an 
ESD workstation. If ESD workstation is not available, use appropriate ESD protection by wearing an antistatic wrist strap 
attached to the chassis ground (any unpainted metal surface) on the board when handling parts. 

Handling Boards 

CY3676 Evaluation Kit is sensitive to ESD. Hold the board only by its edges. After removing the board from its box, place it 
on a grounded, static free surface. Use a conductive foam pad if available. Do not slide board over any surface. 

Certification Disclaimer  

This kit is intended for demonstration, evaluation or development purposes only and is not considered by Cypress 
Semiconductor to be a finished end-product fit for general consumer use. It generates and can radiate radio frequency energy 
and has not been specifically tested for CE certification compliance. Operation of this equipment in other environments may 
cause interference with radio communications, in which case the user at their own expense will be required to take whatever 
measures may be required to correct this interference. 

 



 

CY3676 Evaluation Kit User Guide, Doc. No. 002-11165 Rev. *A 6 

1 Introduction 

  

Thank you for your interest in the CY3676 Evaluation Kit (EVK). The CY3676 EVK is designed to enable you to evaluate the 
programmable clock device CY29412, the latest addition to programmable devices in Cypressôs timing product portfolio. The 
CY29412 is a high performance programmable oscillator with one fractional PLL that generates any frequency up to 2.1 GHz 
with jitter as low as 110 fs. The device offers one differential output. The CY29412 comes in an 8-pin LCC package for 
industrial applications. The differential I/O standards supported are LVDS, LVPECL, High-Speed Current Steering Logic 
(HCSL) and Current Mode Logic (CML). The device also supports features like a Voltage-Controlled Crystal Oscillator 
(VCXO), and provides the user with an I2C programming interface.  

The CY3676 EVK allows you to evaluate both AC and DC parameters of the output signals by making required on-board 
termination settings. 

The CY3676 EVK is available through the Cypress Online Store or through our distributors. 

1.1 CY3676 EVK Contents 

The CY3676 EVK includes the following: 

¶ CY3676 Evaluation Board  

¶ USB Standard-A to Mini-B cable 

¶ Quick Start Guide 

Figure 1-1. CY3676 Kit Contents 

 
 

Inspect the contents of the kit. If you find any part missing, contact your nearest Cypress sales office for assistance: 
www.cypress.com/support. 

 

http://www.cypress.com/cypress-store
http://www.cypress.com/support
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1.2 Getting Started 

To learn the solution quickly and apply it to your design, refer to the CY3676 Quick Start Guide inside the kit box or in the 
I nstallation  directory. The default location for the kit documents is: 

<Install_Direct ory> \ CY3676 Evaluation  Kit \ <version> \ Documentation   

This guide will help you get acquainted with the CY3676 EVK: 

The Software Installation chapter describes the installation of the kit software.  

The Kit Operation chapter describes the major features of CY3676 Evaluation Kit. 

The Hardware chapter describes the hardware content of the CY3676 Evaluation Kit and the hardware operation.  

The Example Projects chapter describes the multiple projects that will help you understand how to evaluate different 
supported output standards on this kit.  

The Appendix captures DC/AC Measurements of Clock Outputs, Schematics, Fab Drawing, and the bill of materials (BOM). 

1.3 Additional Learning Resources 

Visit www.cypress.com/CY3676 and www.cypress.com/HPO for additional learning resources including datasheets and 
application notes. 

1.4 Technical Support 

For assistance, go to: www.cypress.com/support, or contact our customer support at +1(800) 541-4736 Ext. 2 (in the USA), 
or +1 (408) 943-2600 Ext. 2 (International). 

1.5 Document Conventions 

Table 1-1. Document Conventions for Guides 

Convention Usage 

Courier New 
Displays file locations, user entered text, and source code: 

C:\ ...cd\icc\ 

Italics Displays file names and reference documentation. 

[Bracketed, Bold] 
Displays keyboard commands in procedures: 

[Enter] or [Ctrl] [C] 

File > Open 
Represents menu paths: 

File > Open > New Project 

Bold 
Displays commands, menu paths and icon names in procedures: 

Click the File icon and then click Open. 

Times New Roman 
Displays an equation: 

2 + 2 = 4 

Text in gray boxes Describes Cautions or unique functionality of the product. 

  

http://www.cypress.com/CY3676
http://www.cypress.com/HPO
http://www.cypress.com/support
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1.6 Acronyms 

Table 1-2. List of Acronyms used in this Document 

Acronym Definition 

BOM Bill of Materials 

CML Current Mode Logic 

DNP, DNM Do Not Populate, Do Not Mount 

HCSL High-Speed Current Steering Logic 

I2C Inter-Integrated Circuit 

JEDEC Joint Electron Device Engineering Council 

LDO Low-Dropout 

LVPECL Low Voltage Positive Emitter Coupled Logic 

LVPECL2 Low Voltage Positive Emitter Coupled Logic with zero Common-mode current 

LVDS Low Voltage Differential Signaling 

OE Output Enable 

SMA Subminiature Version A 

VCXO Voltage Controlled Crystal Oscillator 

OTP One-Time Programmable 
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2 Software Installation 

 

This chapter describes the steps to install the software tools and packages on a PC for using the CY3676 Evaluation Kit.  

2.1 Before You Begin 

All Cypress software installations require administrator privileges. Ensure that you have the required privileges on the system 
for successful installation. Before you install the kit software, close any other Cypress software that is currently running. 

2.2 Install Software 

Follow these steps to install the CY3676 Evaluation Kit software:  

1. Download the CY3676 Evaluation Kit software from www.cypress.com/CY3676. The software is available in the following 
formats: 

a. CY3676 Evaluation Kit Complete Setup: This installation package contains the files related to the CY3676 

Evaluation Kit. However, it does not include the Windows Installer or Microsoft .NET Framework packages. If these 
packages are not available on your computer, the installer directs you to download and install them from the Internet. 

b. CY3676 Evaluation Kit Only: This executable file installs only the CY3676 EVK contents, which include example 

projects, hardware files, and user documents. This package can be used if all the software prerequisites (listed in 
step 4) are installed on your PC. 

c. CY3676 Evaluation Kit ISO: This file is a complete package, stored in a CD/DVD-ROM image format that you can 

use to create a CD/DVD or extract using an ISO extraction program such as WinZip or WinRAR. The file can also 
be mounted similar to a virtual CD/DVD using virtual drive programs such as Virtual CloneDrive and MagicISO. This 
file includes all the required software, utilities, drivers, hardware files, and user documents. 

2. If you have downloaded the ISO file, mount it on a virtual drive. If you do not have a virtual drive to mount, extract the 
ISO contents using the appropriate ISO extractor (such as MagicISO or PowerISO). Double-click cyautorun.exe in the 
root directory of the extracted content or the mounted ISO if the ñAutorun from CD/DVDò option is not enabled on the PC. 
The installation window will appear automatically.  

Note: If you are using the ñKit Complete Setupò or ñKit Onlyò file, then go to step 4 for installation. 

3. Click Install CY3676 EVK to start the installation as shown in Figure 2-1. 

  

http://www.cypress.com/CY3676
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Figure 2-1. Installer Screen 

 

 

4. Click Changeé if you want to install the CY3676 EVK in a location other than the default, and then click Next as shown 

in Figure 2-2. 

Note: When you click Next, the CY3676 EVK installer automatically installs the required software, if it is not present on 

your computer. The pre-requisites are ClockWizard 2.1 and PSoC Programmer 3.25.0 or later. 

Figure 2-2. InstallShield Wizard 
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5. Select the Installation Type (see Figure 2-3). The drop-down menu contains three options: Typical (installs all the 
required features), Custom (lets you choose the features to be installed), and Complete (installs all the contents). Click 
Next after you select the Installation Type. 

       Note: It is recommended that you choose the Typical Installation Type. 

Figure 2-3. Product Installation Overview 

 
 

6. Read and accept the End-User License Agreement, and then click Next. 

When the installation begins, a list of packages appears on the Installation page. A green check mark appears next to 
each package after successful installation. 

7. Enter your contact information or select the Continue Without Contact Information check box. 

8. Click Finish to complete the CY3676 EVK installation.  

After the installation is complete, the kit contents are available in the following location:  

<Install_Directory> \ CY3676 Evaluation Kit \ <version>.    

Default location: 

Windows 7 (64-bit): C: \ Program Files (x86) \ Cypress \ CY3676 Evaluation  Kit   

Windows 7 (32-bit): C: \ Program Files \ Cypress \ CY3676 Evaluation  Kit   
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2.3 Install Hardware 

No additional hardware installation is required for this kit. 

2.4 Uninstall Software 

You can uninstall the software using one of the following methods: 

¶ Go to Start > All Programs > Cypress > Cypress Update Manager > Cypress Update Manager, and select the 
specific software package. Click the Uninstall button. 

¶ Go to Start > Control Panel > Programs and Features, and select the specific software package. Click the 
Uninstall/Change button. 
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3 Kit Operation 

 

The CY3676 EVK can be used to evaluate the CY29412, a high performance programmable oscillator. Connect the CY3676 
kit through a USB cable to a PC running Cypressôs ClockWizard 2.1 software. The clock device CY29412 can be configured 
and programmed to generate frequencies with best-in-class performance. 

3.1 Theory of Operation 

The CY3676 EVK offers one differential clock output for evaluation. The CY29412 device is available with a crystal embedded 
inside the package. There is no requirement for an external clock source or on-board crystal for this kit.  

The kit is capable of generating fixed 3.3 V, 2.5 V, and 1.8 V voltages from a 5 V USB port. The on-board PSoC 5LP (U7) 
performs USB-to-I2C conversion. There is one power LED (LED2) driven from the 5 V USB supply and one status LED (LED1) 
controlled by the PSoC 5LP. The output of the LDO regulator (U8) is configurable (3.3 V, 2.5 V, or 1.8 V) through jumper J13.  

Note: An additional on-board LDO (U9 ï not shown here) generates a fixed 3.3 V supply for the PSoC 5LP in the CY3676 
Rev ** EVK. This feature has been changed in CY3676 Rev *A EVK where the PSoC 5LP is directly powered by 5V USB 

supply. The CY3676 kit revision is printed on the label at the back of the kit box. 

Figure 3-1 illustrates the block diagram of the CY3676 EVK. 

Figure 3-1. CY3676 EVK Block Diagram 

 



 Kit Operation 

CY3676 Evaluation Kit User Guide, Doc. No. 002-11165 Rev. *A 14 

3.2 Functional Description 

The differential clock outputs (J6, J7) are driven out on to SMA connectors. The EVK is populated with 50 W resistors (R30 
and R31) for output termination. The termination options of the differential outputs in the evaluation board are listed in the 
Hardware chapter. These termination circuits are designed to terminate the output clocks in LVPECL, LVDS, HCSL, 
LVPECL2, and CML signal types by populating, or by not populating the J5 jumper shunt. 

Figure 3-2 illustrates the top and bottom view of the CY3676 EVK. 

 Figure 3-2. CY3676 EVK (Top View, Bottom View)  

 

                   CY3676 EVK Top View           CY3676 EVK Bottom View 

3.3 CY3676 EVK USB Connection 

The clock device CY29412 on the kit is not loaded with any default configuration. To view and evaluate different configurations 
on an oscilloscope (or other standard instruments), the clock device must be programmed with the desired configuration. The 
ClockWizard 2.1 application is required for programming any configuration. Therefore, the kit should be connected  
(see Figure 3-3) to the PC through the USB connection for programming. 

Figure 3-3. Kit Connected through USB 
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The kit enumerates as a USB Composite Device as part of the Driver Software Installation on Windows. 

Figure 3-4. USB Driver Installation 

 

 

After the driver installation is complete, the device is ready to use. 

Figure 3-5. USB Driver Installation Complete 

 

 

3.4 Programming the CY29412 

The CY29412 device has internal one-time programmable (OTP) nonvolatile memory called eFuse. The device also contains 
volatile memory that stores an exact copy of the eFuse at the release of reset at power up. The output frequency depends on 
the configurations in the volatile memory. Writing the entire device configuration in the volatile memory section of a blank 
device after power up is called Functional Programming. The CY3676 kit is shipped with a blank CY29412 device. This kit 
can be used to check both the Functional and eFuse Programming of the device using ClockWizard 2.1. See Functional 
Programming of the CY29412 and eFuse Programming of the CY29412 for details. 

3.5 Functional Programming of the CY29412 

ClockWizard 2.1 is used for functional programming of the CY29412. A configuration created in ClockWizard 2.1 can be 
downloaded to the volatile memory section of the device.  

The example ClockWizard 2.1 projects can be found at the following location: 

<Install_Directory> \ CY3676 Evaluation Kit \ <version> \ Firmware \ Example Projects  

Configuration profiles generated from these projects can be used to evaluate the CY29412 device on the CY3676 EVK. Refer 
to Functional Programming for the kitôs hardware settings prior to programming. It is recommended that you copy the example 
projects to another location if you want to make any modifications to the settings so that the default project is retained in the 
installation directory. 

CAUTION 

Before programming the CY3676 EVK through ClockWizard 2.1, it is recommended to go through 
the Hardware section of this user guide. The mismatch between the hardware settings and the 
ClockWizard 2.1 configuration may cause potential damage of the EVK. Specifically, the voltage 
setting on the kit selected with J13 must match the voltage setting within the configuration to be 
programmed. 
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3.5.1 Generating and Programming the Device Configuration Profile 

The ClockWizard 2.1 is used to generate profiles and to perform functional programming of the device.   

1. Verify that the power supply voltage jumper is set for the voltage used in the project that you intend to program. See the 
Hardware section for details. 

2. Connect the CY3676 EVK to your PC through the supplied USB cable. 

3. To launch the ClockWizard 2.1 application, go to Start > All Programs > Cypress > ClockWizard 2.1.  

The workspace files are located in the Workspace folders. The four workspaces available are: 

¶ CY3676_LVPECL_3p3_156p25.cpj 
¶ CY3676_LVDS_2p5_50.cpj 

¶ CY3676_HCSL_2p5_100.cpj 

¶ CY3676_HCSL_1p8_156p25.cpj 

4. Select the File menu in ClockWizard 2.1, select Open workspace, browse the required workspace file with a .cpj 
extension, and then click Open. Each Workspace file can contain multiple projects. 

5. Click Configure, as shown in Figure 3-6. 

6. Click the Generate button. This will generate the JEDEC file for the configuration selected. The various configuration 

parameters appear on the right panel of the block diagram in the tabbed interface. For more information on configuration 
parameters, refer to the ClockWizard 2.1 User Guide located in Help > User guide of the ClockWizard 2.1 software.  

Figure 3-6. Generating a Configuration Profile using ClockWizard 2.1  

 
 

7. Click Results to view the results generated from this configuration as shown in Figure 3-7. 
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Figure 3-7. View Results Generated from the Configuration Profile using ClockWizard 2.1 

 

8. To program the CY29412 device, select Program in the left navigation pane, as shown in Figure 3-8. Choose the 
appropriate device in the Select Device (I2C Master) drop-down list prior to programming, and then click the Functional 
Program button. This will program the device directly from ClockWizard. LED1 blinks to indicate that the device is being 

programmed. 

For more information, refer to the ClockWizard 2.1 User Guide located in Help > User guide of the ClockWizard 2.1 

software. 

Figure 3-8. Programming Configuration Profile using ClockWizard 2.1 

 












































