Copyrights

© Cypress Semiconductor Corporation, 2007–2012. The information contained herein is subject to change without notice. Cypress Semiconductor Corporation assumes no responsibility for the use of any circuitry other than circuitry embodied in a Cypress product. Nor does it convey or imply any license under patent or other rights. Cypress products are not warranted nor intended to be used for medical, life support, life saving, critical control or safety applications, unless pursuant to an express written agreement with Cypress. Furthermore, Cypress does not authorize its products for use as critical components in life-support systems where a malfunction or failure may reasonably be expected to result in significant injury to the user. The inclusion of Cypress products in life-support systems application implies that the manufacturer assumes all risk of such use and in doing so indemnifies Cypress against all charges.

Trademarks

PSoc Designer™ and Programmable System-on-Chip™ are trademarks and PSoC® is a registered trademark of Cypress Semiconductor Corp. All other trademarks or registered trademarks referenced herein are property of the respective corporations.

Source Code

Any Source Code (software and/or firmware) is owned by Cypress Semiconductor Corporation (Cypress) and is protected by and subject to worldwide patent protection (United States and foreign), United States copyright laws and international treaty provisions. Cypress hereby grants to licensee a personal, non-exclusive, non-transferable license to copy, use, modify, create derivative works of, and compile the Cypress Source Code and derivative works for the sole purpose of creating custom software and or firmware in support of licensee product to be used only in conjunction with a Cypress integrated circuit as specified in the applicable agreement. Any reproduction, modification, translation, compilation, or representation of this Source Code except as specified above is prohibited without the express written permission of Cypress.

Disclaimer

CYPRESS MAKES NO WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, WITH REGARD TO THIS MATERIAL, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. Cypress reserves the right to make changes without further notice to the materials described herein. Cypress does not assume any liability arising out of the application or use of any product or circuit described herein. Cypress does not authorize its products for use as critical components in life-support systems where a malfunction or failure may reasonably be expected to result in significant injury to the user. The inclusion of Cypress’ product in a life-support systems application implies that the manufacturer assumes all risk of such use and in doing so indemnifies Cypress against all charges.

Use may be limited by and subject to the applicable Cypress software license agreement.
# Contents

1. **Introduction** .................................................................................................................................................. 5
   1.1 Introduction to PSoC Programmer .................................................................................................................. 5
   1.2 Installing PSoC Programmer .......................................................................................................................... 5

2. **Using PSoC Programmer** .............................................................................................................................. 7
   2.1 Starting PSoC Programmer ............................................................................................................................. 7
   2.2 Loading a File .................................................................................................................................................. 8
      2.2.1 Recent Files ............................................................................................................................................. 8
   2.3 Documentation .............................................................................................................................................. 9
   2.4 Selecting a Port ............................................................................................................................................ 9
   2.5 Selecting a Device ......................................................................................................................................... 10
   2.6 Selecting Programmer Options ................................................................................................................... 11
      2.6.1 Auto-Update of Firmware ...................................................................................................................... 11
      2.6.2 Auto-Reset of Chip ................................................................................................................................. 11
      2.6.3 Chip Lock ............................................................................................................................................... 11
      2.6.4 Partial Program ........................................................................................................................................ 12
      2.6.5 Clear EEPROM ..................................................................................................................................... 12
   2.7 Setting Programming Parameters .............................................................................................................. 12
      2.7.1 Programming Mode .................................................................................................................................. 12
      2.7.2 Clock Speed (MiniProg3 only) .................................................................................................................. 12
      2.7.3 Protocol .................................................................................................................................................. 12
      2.7.4 Pin Connector (MiniProg3 only) .............................................................................................................. 13
   2.8 Selecting a Pin Connector (MiniProg3 Only) ................................................................................................. 13
   2.9 Programming a Device .................................................................................................................................. 13
      2.9.1 To turn verification off ............................................................................................................................. 13
   2.10 Stopping a Process ...................................................................................................................................... 13
   2.11 Error Messages ........................................................................................................................................... 14
   2.12 Reading a Device ........................................................................................................................................ 15
      2.12.1 Protected Block Modes .......................................................................................................................... 16
   2.13 EEPROM Programming ............................................................................................................................... 16
   2.14 Using Checksum ......................................................................................................................................... 16
   2.15 Erasing Flash Memory .................................................................................................................................. 16
      2.15.1 Erasing a Block ................................................................................................................................... 16
      2.15.2 Erasing the Entire Flash Contents ....................................................................................................... 17
   2.16 JTAG Programming Protocol ..................................................................................................................... 17
2.16.1 Serial Programming Features ................................................................. 18
2.17 Using the Patch Image Option ................................................................. 18
2.18 Verify Programming ............................................................................... 18
2.19 Upgrading Firmware ............................................................................. 18
  2.19.1 ICE Cube ......................................................................................... 18
  2.19.2 MiniProg1 ....................................................................................... 18
  2.19.3 MiniProg3 ....................................................................................... 19
  2.19.4 TrueTouch Bridge ........................................................................... 19
  2.19.5 FirstTouch, FirstTouchRF .............................................................. 19
  2.19.6 FTK3/5, DVKProg3/5 .................................................................... 19
3. Technical Support ....................................................................................... 20
  3.1 Online and Telephone Support ............................................................ 20
  3.2 Product Upgrades ............................................................................... 20
Revision History ......................................................................................... 22
  Document Revision History ................................................................. 22
1. Introduction

1.1 Introduction to PSoC Programmer

PSoC Programmer is a flexible, stand-alone utility for programming PSoC devices. Used with both PSoC Designer and PSoC Creator, PSoC Programmer offers you a simple GUI that connects to programming hardware. Also included is a COM layer that you can use to create custom applications.

If you are new to PSoC Programmer, you must first install it and then set the options you want to use. You then use PSoC programmer to:

- Open a hex file
- Select a communication port
- Select a device
- Set programming parameters
- Program a device
- Verify programming

1.2 Installing PSoC Programmer

You can download PSoC Programmer directly from the Cypress web site. You can then install it on your PC.

2. Find the PSoC Programmer.exe file in the table and download the file.
3. Click PSoCProgrammersetup.exe to start the setup wizard.
4. Follow the on-screen prompts to install PSoC Programmer.

If you have PSoC Programmer version 3.06 on your computer, use Add/Remove Programs to remove it before you begin this installation procedure. If you installed a previous version of PSoC Programmer using the CyInstaller, navigate to the Update Manager to update to the latest version of PSoC Programmer or to uninstall it.
Figure 1. Cypress Update Manager
2. Using PSoC Programmer

2.1 Starting PSoC Programmer

You can start PSoC Programmer from the Windows desktop or through PSoC Designer. Set up all hardware, including the device to program, before you start PSoC Programmer.

To start PSoC Programmer from the desktop

Click Windows Start > Programs > Cypress > PSoC Programmer > PSoC Programmer. The PSoC Programmer main window appears.

To start PSoC Programmer from PSoC Designer

1. Load the target project that contains the hex file and the device you want to program.
2. Click Program.
2.2 Loading a File

You must load a hex file into PSoC Programmer before programming a device. PSoC Programmer only programs devices using hexadecimal files (*.hex). If your project is not yet compiled into hexadecimal format, use PSoC Designer or PSoC Creator to prepare your project for programming before you continue.

1. Select File > File Load or press [F4].
2. In the Open dialog box, browse to the folder containing the file, then click the file name.
3. Click Open.

2.2.1 Recent Files

PSoC Programmer maintains a list of last five used hex files. You can access the recent used hex files from the File > Recent Files menu or from the next to File Open button in the toolbar. You would either see a complete or truncated file path with the hex file name. When you mouse over the displayed hex file a tooltip provides full file path with the last modified date. Click on a hex file to load it.

Note: If you move or delete a hex file, when PSoC Programmer starts its reference will be removed from the Recent Files list.

Here are two screens that illustrate the different ways to access recent files.

Access recently used hex files from the toolbar

Access recently used hex files from the “File” menu
2.3 Documentation

You can open any documentation file from within PSoC Programmer by using the Help menu. When you select Documentation from Help menu a dialog box opens and you can open any file you in which you have an interest.

The default path is [INSTALL PATH]\Cypress\Programmer\x.y.z\Documents\n
Note: x.y.z is the PSoC Programmer release number.

2.4 Selecting a Port

The following table shows the devices that are supported.

<table>
<thead>
<tr>
<th>Devices</th>
<th>Protocols</th>
<th>Power</th>
<th>Power Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>ICE Cube</td>
<td>ISSP</td>
<td>3.3, 5.0</td>
<td>Internal/External</td>
</tr>
<tr>
<td>FirstTouch</td>
<td>ISSP</td>
<td>5.0</td>
<td>Internal</td>
</tr>
<tr>
<td>FirstTouchRF</td>
<td>ISSP</td>
<td>5.0</td>
<td>Internal</td>
</tr>
<tr>
<td>MiniProg1</td>
<td>ISSP</td>
<td>5.0</td>
<td>Internal</td>
</tr>
<tr>
<td>MiniProg3</td>
<td>ISSP/SWD/JTAG</td>
<td>1.8, 2.5, 3.3, 5.0</td>
<td>Internal/External</td>
</tr>
<tr>
<td>TrueTouch Bridge</td>
<td>ISSP/SWD</td>
<td>UCOM: 1.8 - 5.0 VAUX: 1.8 - 5.0</td>
<td>Internal/External</td>
</tr>
<tr>
<td>FTK3</td>
<td>SWD</td>
<td>3.3</td>
<td>External</td>
</tr>
<tr>
<td>DVKProg3</td>
<td>SWD</td>
<td>3.3</td>
<td>External</td>
</tr>
<tr>
<td>FTK5</td>
<td>SWD</td>
<td>3.3</td>
<td>External</td>
</tr>
<tr>
<td>DVKProg5</td>
<td>SWD</td>
<td>3.3</td>
<td>External</td>
</tr>
</tbody>
</table>

To select a port, select it from the Port Selection list on the left side of the PSoC Programmer window.

USB ports are added to the port list automatically when a programming device is connected and removed from the list when disconnected. When changing ports, PSoC Programmer attempts to connect to the selected port, and then displays the port status in the lower-right corner of the window along with a status message in the main window.
The following list describes the current port options.

- **USB/yywwDnnn** – The "D" signifies a USB adapter. Programming goes through the selected USB port to an ICE Cube or ICE-4000. yy = production year, ww = production work week, and nnn = serial number.

- **USB/yywwXnnn** – The "X" can be any letter other than "D". "X" signifies an ICE-Cube USB port. Programming goes through the USB port to an ICE Cube or ICE-4000. yy = production year, ww = production work week, and nnn = serial number.

- **MiniProg** – XXXXXXX. This version supports Miniprogs1 and Miniprogs3.

- **First Touch** – XXXXXXX

When changing ports, PSoC Programmer attempts to connect to the selected port and displays the port status in the lower right corner of the window. If you were previously connected to a device on another port, PSoC Programmer will disconnect from the original device before connecting to the new device.

USB ports are added to the port list automatically when a programming device is connected. They are removed from the list when a device is disconnected.

Setting a base and a part device allows the programming operations to perform actions based upon the characteristics of the PSoC device. For example, CY8C24794 parts require Power Cycle programming mode because the reset pin is not available for Reset programming mode. Flash sizes, which are important when the verify operation is performed, are determined by selecting a PSoC device. Changing the device enables or disables programming mode options and displays Flash size information in the status window.

### 2.5 Selecting a Device

By default, PSoC Programmer is set to automatically detect the device. PSoC Programmer queries the device and then sets the device based on the result. Setting a base and part device allows the programming operations to perform actions based on the characteristics of the device. Flash sizes, which are important when the verify operation is performed, are also determined by device. Changing the device enables or disables programming mode options and displays Flash size information in the status window.

Devices are grouped by family with the last five digits of the device code signifying the family. For example: Device Family 29X66 contains CY8C29466, CY8C29566, CY8C29666, and CY8C29866.

**To select a device**

Click the **Program** button when you are ready to program. The correct device is automatically selected.

**To select a device with AutoDetection off**

1. Click the **Device Family** drop-down list and select the target device family.
2. Click the **Device** drop-down list and select the target device associated with the target device family.
2.6 Selecting Programmer Options

Select Options > Programmer Options to bring up the following dialog box for setting PSoC Programmer options.

Here are the options you can choose:

2.6.1 Auto-Update of Firmware

You can enable automatic firmware upgrades for programmer hardware. These auto updates apply to all programmers that support the in-field upgrade of firmware. You can change this setting at any time, even when PSoC Programmer is not connected. Your selection is retained after the application is closed.

2.6.2 Auto-Reset of Chip

You can enable or disable toggling of the XRES line after any programmer operation (Program, Checksum, Read, and so on) is finished. This option is applicable only if the chip is acquired in Reset mode.

2.6.3 Chip Lock

You can enable or disable programming of Write Once Latch (WOL) for PSoC 3 and PSoC 5 devices. This option is disabled by default.

Select the check box beneath this option if you want to receive a popup warning before programming, as shown in the following figure.

Your selection is retained after the application is closed.
The following occurs when the WOL option is enabled:

- After you click the Program button, the warning shown in the previous figure appears. You can click OK to continue or Cancel to stop the operation.
- If the "Do not show this message again" check box is selected, the popup warning does not appear the next time you attempt to program the device using this Chip Lock option.
- When SWD protocol is selected and the Chip Lock option is enabled, the Log window displays, in red text: “Chip Lock option is enabled, the target device can be locked if programmed.”

2.6.4 Partial Program

If you enable the Partial Program option, PSoC Programmer uses partial programming methodology to program the PSoC 3 / PSoC 4 / PSoC 5 chips. This allows writing nonzero blocks from the hex image to the chip’s area flash, which reduces the programming time, most notably on the FTK3/5 programmers.

2.6.5 Clear EEPROM

When enabled, this option allows you to clear EEPROM data after programming on PSoC 3 and PSoC 5 chips. This action will write zero values in all EEPROM locations. This option is disabled by default.

PSoC Programmer does not support EEPROM programming from the GUI. For more information, see EEPROM Programming.

2.7 Setting Programming Parameters

Before you program or use any other PSoC Programmer functions, you must set the correct programming parameters:

- Programming mode
- Clock speed (MiniProg3 when using JTAG protocol only)
- Protocol
- Pin connector (MiniProg3 only)

You can set these options from the Programmer tab in the PSoC Programmer window.

2.7.1 Programming Mode

Programming mode determines how PSoC Programmer acquires the device for programming. There are three modes:

- **Reset** – Used for ISSP header programming on a self-powered target application board. In this case, the target board supplies the power and the programmer uses the reset pin to acquire. You cannot use Reset mode with 8-pin devices
  Select the Power Device check box with Reset mode if your target board is not self-powered
- **Power Cycle** – Used for programming when the programmer requires power. The programmer cycles power to acquire. You can use Power Cycle mode only with devices that have an XRES pin.
  Select the Power Device check box with Reset mode if your target board is not self-powered
- **Power Detect** – Used for programming when the programmer detects the power applied to the board. This is available for Miniprosg3 and CY3207ISSP hardware.

2.7.2 Clock Speed (MiniProg3 only)

Clock speed for Miniprosg3 is selectable if you use JTAG programming protocol. The selectable clock speeds are 48 Mhz, 24 Mhz, 16 Mhz, 12 Mhz, 8 Mhz, 6 Mhz, 3.2 Mhz, 3.0 Mhz, 1.6 Mhz, and 1.5 Mhz.

2.7.3 Protocol

PSoC Programmer supports the ISSP, SWD, and JTAG protocols. It is important to set the protocol for the device before programming.

The table in Selecting a Port shows the supported devices with protocols.
2.7.4 Pin Connector (MiniProg3 only)

This option is supported only for MiniProg3 devices. For more information, see Selecting a Pin Connector (MiniProg3 Only).

2.8 Selecting a Pin Connector (MiniProg3 Only)

The Connector option is available in the Programmer tab of PSoC Programmer. It is applicable only for the MiniProg3 device. For all other programmers, it is disabled.

The MiniProg3 communicates with PSoC devices through the 5-pin or 10-pin headers, as shown in the following figure.

- The 5-pin ISSP connector is used for ISSP, I²C, and SWD programming.
- The 10-pin connector is used for SWD and JTAG programming.

Before you perform any actions with PSoC devices, set the correct connector using the radio buttons, as shown in the following figure.

2.9 Programming a Device

PSoC Programmer programs devices using hexadecimal files (*.hex). You must load the file into PSoC Programmer before the programming a device.

To program a device

1. Click the Connect button.
2. Click Program or press [F5].

The programming operation erases, programs, verifies, protects, and performs a checksum. Because the verify action is performed before the protect action, all blocks are verified.

2.9.1 To turn verification off

When you are debugging your program, you may be making changes, rebuilding, and reprogramming a device very frequently. To save some time during this process, you can select to turn the Verification stage off. This saves roughly 30 percent of the total programming time. You should not turn verification off for production programming.

2.10 Stopping a Process

You can stop programming and other long processes.

The Abort Process button is enabled only during the busy state of PSoC Programmer. The busy state means that the programmer is executing a long-lasting action such as Program, Verify, Checksum, Read, or Upgrade Firmware. You can click the Abort Process button at any time during a busy state to stop the current operation.

This is particularly useful if you click Program when a PSoC device is not connected to the programmer or when attempting to acquire a device using the Reset mode when the device is not powered. The Acquire operation takes about 20 seconds to time out. If you stop the process, you do not have to wait for the timeout period to finish.
## 2.11 Error Messages

This topic shows some common error messages displayed when using PSoC Programmer, along with possible solutions.

### Cannot open port

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>The USB cable is detached from either the USB adapter or the computer.</td>
<td>Plug in the cable, wait a few seconds, and then press the Connect ICE icon in the Debugger subsystem.</td>
</tr>
</tbody>
</table>

### Programming step failed

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>A step within the programming algorithm (Erase, Verify, Program, Protect, and so on) failed.</td>
<td>Update Miniprog1 to the latest firmware. Click the Erase button to start the Erase function, and then try to program the device again. Check connections; SDATA/SCLK lines may be disconnected.</td>
</tr>
</tbody>
</table>

### Project is incompatible with the pod/chip

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>The wrong project is selected for the pod.</td>
<td>Verify that the project matches the pod type.</td>
</tr>
</tbody>
</table>

### Could not configure ICE

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Port setting incorrect.</td>
<td>Select the correct port from the Port Selection list.</td>
</tr>
<tr>
<td>Power disconnected.</td>
<td>Check power cord connections.</td>
</tr>
<tr>
<td>USB cable disconnected.</td>
<td>Check USB cable connections.</td>
</tr>
</tbody>
</table>

### Cannot acquire device

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cannot acquire the device.</td>
<td>Verify that the programmer is plugged in, check for broken wiring, confirm that the connection is secure, and determine that the PSoC chip is working correctly. Make sure the programming mode is correct. Setting the mode to Power Cycle when the chip already has external power, results in a “Can’t Acquire Device” error. Similarly, setting the mode to Reset if there is no external power, also results in this error. Make sure the adapter is correctly used, and that pin 1 is properly aligned. The MiniProg1 may have two capacitors connected to the SDATA and SCLK lines. Contact Cypress Technical Support for directions on how to remove the capacitors.</td>
</tr>
</tbody>
</table>

### Device not supported

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Programmer generates the error message, “This device is not supported by this programmer/port”.</td>
<td>These parts can only be programmed by an ICE-4000: CY8C26233 CY8C26433 CY8C26633</td>
</tr>
</tbody>
</table>

### PSoC Programmer has expired or will expire

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>During launch, PSoC Programmer displays a warning message that says it is expired.</td>
<td>When the warning message appears, click Yes to go to the PSoC Programmer website and download the latest version of PSoC Programmer.</td>
</tr>
</tbody>
</table>
MiniProg is listed as MINIProg1/1 in the port list or MiniProgrammer not programmed

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>If the MiniProg firmware is corrupted, the MiniProg is listed in the Port menu as MINIProg1/1, and a message in the Results pane says, &quot;MiniProgrammer not programmed. Downloading Firmware.&quot; A follow-up message will state, &quot;Can't open MINIProg1/1 port, check connections.&quot;</td>
<td>If the firmware is corrupted, PSoC Programmer will update the firmware automatically (indicated by the green, blinking LED on the MiniProg). After the firmware is updated (usually less than one minute), you must unplug the MiniProg from the USB and plug it back in before you can select the MiniProg from the Port list.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Results</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Can't open MINIProg1/1 port, check connections</td>
<td></td>
</tr>
<tr>
<td>Please unplug MiniProgrammer from USB and reconnect</td>
<td></td>
</tr>
<tr>
<td>Update firmware using Utilities/Upgrade Firmware</td>
<td></td>
</tr>
<tr>
<td>MINI version Expecting 1.73 not 0.0</td>
<td></td>
</tr>
<tr>
<td>Done</td>
<td></td>
</tr>
<tr>
<td>Starting</td>
<td></td>
</tr>
<tr>
<td>MiniProgrammer not programmed, Downloading Firmware</td>
<td></td>
</tr>
</tbody>
</table>

**2.12 Reading a Device**

Click **Read** or press [F7] to read the contents of a device. Device contents are displayed in hexadecimal format, as shown in the following example.

Read Finished at 11:20:25 AM

Protected data is displayed as "xx".

```
0000: xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx
0010: xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx
0020: xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx
0030: xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx
0040: xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx
0050: xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx
0060: xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx
0070: xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx
0080: xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx
0090: xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx
00a0: xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx
00b0: xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx xx
00c0: 00 28 4b 51 32 80 04 75 09 00 62 e3 00 08 28 60
00d0: d5 74 a0 4b 18 75 09 00 08 28 53 32 18 75 09 00
00e0: 08 28 a0 1c 53 31 18 75 09 00 08 28 3f 32 47 32
00f0: ff b0 06 5d d5 74 60 d5 18 7a 31 bf eb 8f c9 18
```

Flash Security data is displayed along with the "read" values.

```
--- Flash Security Data ---
0000: W F R U U U U U U U U U U U U
0400: U U U U U U U U U U U U U U U U
0800: U U U U U U U U U U U U U U U U
0c00: U U U U U U U U U U U U U U U U
1000: U U U U U U U U U U U U U U U U
1400: U U U U U U U U U U U U U U U U
1800: U U U U U U U U U U U U U U U U
1c00: U U U U U U U U U U U U U U U U
2000: U U U U U U U U U U U U U U U U
2400: U U U U U U U U U U U U U U U U
2800: U U U U U U U U U U U U U U U U
2c00: U U U U U U U U U U U U U U U U
3000: U U U U U U U U U U U U U U U U
3400: U U U U U U U U U U U U U U U U
3800: U U U U U U U U U U U U U U U U
3c00: U U U U U U U U U U U U U U U U
```
2.12.1 Protected Block Modes

<table>
<thead>
<tr>
<th>In PSoC Programmer</th>
<th>Description</th>
<th>Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>U = Unprotected</td>
<td>Unprotected</td>
<td>IR ER EW IW</td>
</tr>
<tr>
<td>F = Factory upgrade</td>
<td>Read protect</td>
<td>IR ER EW IW</td>
</tr>
<tr>
<td>R = Field upgrade</td>
<td>Disable external write</td>
<td>IR ER EW IW</td>
</tr>
<tr>
<td>W = Full protection</td>
<td>Disable internal write</td>
<td>IR ER EW IW</td>
</tr>
</tbody>
</table>

E/I - External/Internal; R/W - Read/Write

2.13 EEPROM Programming

Because the PSoC 3 and PSoC 5 hex files do not describe EEPROM data; PSoC Programmer does not support EEPROM programming from the GUI. PSoC Programmer allows you to clear EEPROM data after programming PSoC 3 and PSoC 5 chips, as described in Selecting Programmer Options.

The PSoC Programmer COM does support EEPROM actions at the API level, which allows you to create scripts or utilities that perform EEPROM actions. These examples are detailed in the Examples folder in the root installation directory of PSoC Programmer:

\[INSTALL\PATH\\Cypress\Programmer\x.y.z\Examples\Programming\PSoC3_5\SWD\C_Shar_EEPROM

2.14 Using Checksum

Click Checksum or press [F6] to perform a checksum operation on a device.

If a hex file is loaded, device values are compared to the loaded file. Read and Checksum operations can be completed without a loaded hex file.

2.15 Erasing Flash Memory

The flash memory on the device attached to PSoC Programmer can be erased completely, or block by block.

2.15.1 Erasing a Block

To erase a block, the flash security for the block must be set to U—unprotected. Refer to the PSoC Designer IDE Guide for information about protecting flash.

To erase a block of flash:

1. Select Utilities > Erase Block.
   The Erase Block dialog box appears.
2. Enter the Block ID and Bank ID of the block you want to erase.
3. Click Erase Block.
If the operation succeeds, you will see the message "EraseBlock Succeeded" in the Results area. Otherwise, you will see an error message.

2.15.2 Erasing the Entire Flash Contents

To erase all flash content, select File > Erase All or press [F9]. The Erase All function calls the EraseAll supervisory function which performs a series of steps that destroys the user data in the Flash banks. This function also resets the protection block in each Flash bank to unprotected.

2.16 JTAG Programming Protocol

The JTAG window shows the number of JTAG devices connected in serial. It also displays a diagram of these devices, as shown in the following figure.

- When a Cypress device is connected, the shaded square is populated with appropriate information.
- A non-Cypress device allows you to place the critical IR and DR device information. The Device Properties window is displayed if you click the device within the JTAG display window. You can enter the critical IR and DR identification information and the device name. The IR and DR values are in the range of 1 to 128.
- Each device icon is selectable. You can program the selected target device using the Program button.

When JTAG deducts PSoC 5LP, two devices are shown in the JTAG tab. The first device is shown with TC's ID and second with Cortex-M3 core ID. The detected devices are circled in red rectangle and Cortex-M3 device is switched automatically to program PSoC 5LP silicon correctly.
2.16.1 Serial Programming Features

- **Scan Bus** – You can use MiniProg3 to scan the available device connections. The display window updates the current configuration.
- **Load Setup** – You can load the display information from a .jtc file.
- **Save Setup** – You can save the display information into a .jtc file. This file captures all setup information, which enables you to perform additional work and retain the setting.

2.17 Using the Patch Image Option

To use the Patch Image option, select **File > Patch Image** or press [F12].

You can load a hex file and connect the Minipro1 to the target devices. PSoC Programmer reads the Flash content on the target device and compares it with the selected hex file. Then, the PSoC Programmer replaces the Flash blocks that differ. This feature is useful to replace calibration data or a manufacturing number. See the **PSoC Programmer COM User Guide** and code examples in the root installation folder for more information on writing unique applications to complete specific tasks.

2.18 Verify Programming

To verify device programming, select **Utilities > Verify** or press [F8].

Protected blocks are not verified. If the device is read-protected, the verify operation will fail. Upon completion, PSoC Programmer specifies the number of protected blocks.

The results of the verify procedure fills the text window, flowing up from the initial operation command. To save or copy the results, right-click the text window and then select **Copy** or **Save As** from the drop-down menu.

2.19 Upgrading Firmware

Firmware for programmers must be updated to support new and updated PSoC devices and to apply all of the latest bug fixes.

When PSoC Programmer starts, or when a different port is selected, Programmer checks the connected programming device firmware. If your device firmware is outdated, you will receive a warning similar to the following.

2.19.1 ICE Cube

The ICE Cube updates automatically when PSoC Programmer starts.

2.19.2 MiniProg1

When PSoC Programmer starts, or when a different port is selected, PSoC Programmer checks the connected programming device firmware. If your device firmware is outdated, you will receive a warning similar to the following:

Port Opened with Warnings at 3:13:27 PM MINI version Expecting 1.73 got 1.67

To upgrade the firmware, select **Utilities > Upgrade Firmware**.
2.19.3 MiniProg3
Automatically upgrades FPGA and FX2LP chips when connected to the Programmer GUI. MiniProg3 requires Firmware Upgrade for the PSoC 1 chip. To upgrade the firmware, select **Utilities > Upgrade Firmware**.

2.19.4 TrueTouch Bridge
Upgrades firmware using a bootloader mechanism. TrueTouch Bridge can be in two different states: Normal and Damaged. To upgrade TrueTouch Bridge firmware in the Normal state, select **Utilities > Upgrade Firmware**.

There are cases when TrueTouch Bridge is in the Damaged state. This means that the Bridge is passed in the Bootloader mode. In this mode, it will not appear in the **Port Selection** list. To recover the Bridge from this state, you must upgrade it using the same procedure used in the Normal state,

2.19.5 FirstTouch, FirstTouchRF
Upgrade not supported.

2.19.6 FTK3/5, DVKProg3/5
Automatically when connected to Programmer GUI.
3. Technical Support

3.1 Online and Telephone Support

Free support for PSoC Programmer is available online at www.cypress.com/psoc. Resources include training seminars, discussion forums, application notes, knowledge base articles, and code examples.

Technical Support may also be contacted by phone at 1-800-541-4736.

Before using Cypress support services, know the version of PSoC Programmer installed on your system.

3.2 Product Upgrades

Cypress provides scheduled upgrades and version enhancements for PSoC Programmer free of charge. You can order the upgrades from your distributor on CD-ROM or download them directly from http://www.cypress.com under Software.
## Document Revision History

<table>
<thead>
<tr>
<th>Revision</th>
<th>Issue Date</th>
<th>Origin of Change</th>
<th>Description of Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>**</td>
<td>05/20/2008</td>
<td>FSU</td>
<td>New document.</td>
</tr>
<tr>
<td>*A</td>
<td>06/02/2008</td>
<td>FSU</td>
<td>Fix for defect number 25471.</td>
</tr>
<tr>
<td>*B</td>
<td>09/10/2008</td>
<td>SFV</td>
<td>Fixed revision to *B on page documents.</td>
</tr>
<tr>
<td>*C</td>
<td>11/05/2009</td>
<td>PYRS</td>
<td>Several updates</td>
</tr>
<tr>
<td>*D</td>
<td>05/03/2010</td>
<td>PYRS</td>
<td>New features</td>
</tr>
</tbody>
</table>
| *E       | 11/10/2010 | RAV/ANDE         | Section 3.4 Programmer Options screenshot updated  
|          |            |                  | Section 3.4.3 Partial Program content updated  
|          |            |                  | Section 3.16 Patch Image content updated         |
| *F       | 05/04/2012 | LIRA             | Added section on EEPROM programming.  
|          |            |                  | User Guide is now generated from the same source as Help to eliminate any  
|          |            |                  | synchronization issues. |
| *G       | 09/04/2012 | LIRA             | Added Section 2.2.1 Recent Files  
|          |            |                  | Added Section 2.3 Documentation  
|          |            |                  | Updated Section 2.16 JTAG Programming Protocol |
| *H       | 09/27/2012 | AESA             | Template Updates      |