You are here

Upgrading Older Versions of PSoC® Creator™ BLE Component (1.X) Missing from Newer Releases - KBA215840 | Cypress Semiconductor

Support & Community

Upgrading Older Versions of PSoC® Creator™ BLE Component (1.X) Missing from Newer Releases - KBA215840

Last Updated: August 17, 2016

I get an error message when I try to open my BLE application in PSoC Creator 3.3 and later versions. My application uses the BLE Component version 1.x, and the project is developed in PSoC Creator 3.1. How do I update the Component to the recent version?


The normal Component update process [Project -> Update Components] does not work in this case. The error message appears because the 1.x version of the BLE Component is removed from the PSoC Creator 3.3. Newer releases of PSoC Creator added components including the BLE Component with BLE 4.2 support.

You can update your design to the newest release of the Component. Unlike the regular Component update process, in the case of the BLE Component if you are moving from a 1.X version of the component to a 2.X or later version, you should make the changes detailed in the BLE Component datasheet. See the section “Updating from BLE v1.X to BLE v2.X or later”. The BLE Component datasheet is available here:

Other Workarounds: 

  1. Go back to the older version of PSoC Creator (3.2) and continue using the older version of the Component in your design. PSoC Creator 3.2 and 3.3 can co-exist on your PC, so you could start new designs in 3.3 and still work on your old design in 3.2. You can download PSoC Creator 3.2 from
  2. Use the Archive function to make the older component version available in the newer release of PSoC Creator. However, this is not recommended because the version of the Component is not tested with the new version of PSoC Creator. 

    See ‘Exporting a Component’ and ‘Import Component’ sections of PSoC Creator Help document for more details.

Knowledge Base Tags: 

Provide feedback on this article

Browse KB By Product

Browse KB by Type