You are here

Toolchain Error When Building a PSoC® 5LP Project – KBA87267 | Cypress Semiconductor

Support & Community

Toolchain Error When Building a PSoC® 5LP Project – KBA87267

Last Updated: March 27, 2014

When attempting to build a PSoC® 5LP project on PSoC Creator™, you see the following error:


“No location was selected for the binaries of the tool chain ‘ARM® GCC Generic’. The tool chain will not build until a location is selected. Use Tools > Options > Project Management > Generic Toolchains to set the location of the appropriate binaries.”

What is the cause of this error? What is the solution?

This error occurs when the ARM GCC Generic toolchain has been selected in the Build Settings of your PSoC Creator project, but the location where the toolchain’s binaries are installed on your computer is not specified in the appropriate window (Tools > Options > Project Management > Generic Toolchains) of PSoC Creator.

If you have a generic ARM GCC toolchain installed on your computer, you can point to the location of the toolchain’s binaries in Tools > Options > Project Management > Generic Toolchains and then build your project.

However, if you do not have (or if you do not want to use) a generic ARM GCC toolchain, then you can use the ARM GCC toolchain that is available as a part of the PSoC Creator installation. To select this default toolchain provided with PSoC Creator, do the following:

In your PSoC Creator project screen, click on Project > Build Settings. In the Build Settings window, change the Toolchain option to ARM GCC 4.4.1 then click on Apply and then OK. Now, you should be able to build the project successfully.

Provide feedback on this article

Browse KB By Product

Browse KB by Type