You are here

Keil debugger | Cypress Semiconductor

Support & Community

Keil debugger

Last Updated: October 02, 2011

How do you make it work when the Keil debugger does not start?


The set up of the Keil debugger requires the use of an RS-232 cable.  First determine what port number you are going to use on the computer (or later do it by trail and error if you cannot determine the port number you are using).  Second, ensure the monitor has been down loaded to the development board.  If it is in the default configuration, it will load when the board is plugged into the bus.  To determine if it has been loaded unplug the board and plug it in.Did the green LED on the development board light up? If it did the monitor loaded.  If it did not, open the control panel and select the "Load Mon" button.  The green LED should then light.

Once the monitor is loaded, open the Keil tool and select the debug option and select start.  If you have the evaluation copy it will be reported at this time and you should select ok. The system should load the program and start the debugger at this time.  If it does not, then the communications across the RS-232 did not occur.  Select the setting option, ensure all boxes are checked.  Set the baud rate to 19200 for EZUSB and 38400 for FX and FX2. Select OK and retry the connection. If it still fails, most likely the COM port is not set to the proper one. Go back to the Settings option and select a different port and retry the connect. Do this until you try each of the ports or find the right port.

Knowledge Base Tags: 

Provide feedback on this article

Browse KB By Product

Browse KB by Type