You are here

Device manager sees attached device as 'Unknown Device' | Cypress Semiconductor

Support & Community

Device manager sees attached device as 'Unknown Device'

Last Updated: June 13, 2011

When I run my firmware on the CY3650, under the Device Manager why does the host see my device as an 'Unknown Device'?


Make sure you have the development kit running correctly first. Here're the steps to get the dev kit up and running:

  1. Power the board
  2. Connect the RS232 cable from the computer to the board.
  3. Open the Cypress M8 Monitor software. Go to Communications/Comm Port and make sure the RS232 is connected to the right COM port.
  4. Set the S1 and S3 switch settings as follows. On some boards we have "Open" or "Close" labels for the switches, but others may show "Off" or "On".

        S1 settings:

             Position 1: Off (or Open)- Enable USB Bus Reset
             Positions 2,3,4,5: On (or Closed)- Disable WatchDog Reset, Cext,..
             Position 6,7,8: Off (or Open)- Default

        S3 settings:

             Positions 1,2: Off (or Open)- Program RAM and Run on Reset
             Positions 3 to 8: On (or Closed)- Default

  5. From the M8 Monitor, click on "Dnld Object". Choose a known working firmware such as the mouse reference design and download the .rom file onto the board. You should see the file being downloaded now.
  6. Hit the Red button on the board to reset the board. This step is IMPORTANT!!! Do not forget.
  7. Plug the USB cable from the computer to the board.
  8. Go to My Computer/Device Manager. You should see the mouse being detected under the Mouse section.
Knowledge Base Tags: 

Provide feedback on this article

Browse KB By Product

Browse KB by Type