You are here

CYUSBS232 Android Studio CY7c65213 | Cypress Semiconductor

CYUSBS232 Android Studio CY7c65213

Summary: 1 Reply, Latest post by Haneesh on 05 May 2016 11:05 PM PDT
Verified Answers: 0
Last post
Log in to post new comments.
sabarral_1642256's picture
1 post


My name is sebastian from Argentina

I'm working with CyUsbS232 (Cy7C65123)

I have already tested the kit on Windows, it works ok.

I have also installed the library (.so) and apk on android; and detect the device

whit PID=04B4 and VID=0003

it works ok.

but the sample application has not implemented the use of the UART.

so I got ready to start the project.

but I have tried and tried, and have failed to achieve

my development environment is Windows with Android Studio 2.0

I imported the sample project with the NDK installed; and I could not compile.

I do not need to compile the library, only I intend to use it for UART comunication.

can someone help me?

Haneesh's picture
Cypress Employee
18 posts



Yes, the test utility that comes with USB-serial SDK for android cannot be used for testing UART functionality. It should be used only for I2C/SPI functionality.


Also, note that CY7C65213 can be used in either vendor mode or CDC mode. You need to compile the library only if you are using the device in vendor mode.


To verify the UART functionality in CDC mode, please go through the Knowledge Base article available in the link:


It is suggested to confirm whether the device is configured in Vendor mode or CDC mode using USB-serial configuration utility that comes with Windows SDK.


If you are still facing any trouble, I recommend you to create a technical support request at 




Log in to post new comments.