You are here

In UsbUart demo, CyU3PDebugPrint() can not work? | Cypress Semiconductor

In UsbUart demo, CyU3PDebugPrint() can not work?

Summary: 2 Replies, Latest post by Nageswara Rao Bandaru on 20 Jul 2016 07:50 AM PDT
Verified Answers: 0
Last post
Log in to post new comments.
wangjianhua_1650716's picture
6 posts

I tested, but uart has no output. How can I make the  CyU3PDebugPrint() work in this demo?







mady's picture
Cypress Employee
964 posts


The CyU3PDebugPrint APi will not work in USbUArt Demo Code. The USBUart Democode already has DMA Channels between USB and UART. The CyU3PDebugPrint API will once again try to make use of the DMA Channel, so this will not work.

Other than the debug print, you should be able to see the normal functioning of the code. Any data you send from Serial Terminal from PC will be received by the UART of FX3 and vice versa. If you short the UART Tx and Rx of FX3, you can see that the data being echoed back on serial terminal on PC.


- Madhu Sudhan

Nageswara Rao Bandaru's picture
1 post


We tried to get debug info from the RAID1 application of EZ_FX3S RAID Module board, but we could not.

Connections are as below.

PIN1 and PIN2  of J101, J102, J103, J104 are shorted.  Serial port settings of hyper terminal are 115200 - 8 - None - 1 - None.

We have kept enough prints by using "AppDebugPrint" and as well "Cy3PDebugPrint" in "MSCAppThreadEntry"  function.

Also we tried cyfxuartlpdmamode, and cyfxuartlpregmode programs. But not able to get the transmitted debug info. We connected the serial lines after converting to TTL 5V from RS232 voltage levels.

Your help on this is highly appreciated.


Nageswara Rao


Log in to post new comments.