You are here

Problems with CY7C65211 | Cypress Semiconductor

Problems with CY7C65211

Summary: 2 Replies, Latest post by adun on 04 Apr 2015 04:47 PM PDT
Verified Answers: 0
Last post
Log in to post new comments.
adun's picture
2 posts

I have problem with CY7C65211 on CY8CKIT-049-42xx kit.
I write programm that continously send data to UART. When I send data immediately after power up, USB-Serial adapter misdetected as serial mouse. So I add wait for control packet from PC that enable continous transmission. First time after kit inserted to USB, virtual COM port always successfully open and data transmission start after receiving control packet. If I stop trasmission (send control packet), close port, open port and start tranmission again - all ok. But if I don't stop transmission before close port than next time two cases may occur: 1) error on open port procedure; 2) COM port open successfully, but there is no received data. After this only helps to remove and insert stick again.

Haneesh's picture
Cypress Employee
18 posts

Hi Adun,

Have you tried binding the device to Microsoft CDC driver ? If yes, is the issue still exists ?

You can refer the link: for binding USB serial device to Microsoft CDC driver.




adun's picture
2 posts

Haneesh, thanks for your reply!

I have found that reconnection problem occurs on Windows 7 x64 (USB-serial driver version and Windows XP x32 ( and

Binding USB serial device to Microsoft CDC driver completely solved the problem.

Can you further explain the cause of this problem?

Log in to post new comments.