You are here

on linux(ubuntu10.04) No device found | Cypress Semiconductor

on linux(ubuntu10.04) No device found

Summary: 4 Replies, Latest post by Vine on 14 Feb 2014 04:41 PM PST
Verified Answers: 0
Last post
Log in to post new comments.
ohsh's picture
2 posts


On linux application test(cyusb_linux)

My current development environment

- linux ubuntu10.04(via VirtualBox)

- install(libusb-1.0, qt4)

- Test source : cyusb_linux_1.0.3.tar

test proccess

1. root@my:/cyusb_linux_1.0.3/make

2. root@my:/cyusb_linux_1.0.3/


3.root@my:/cyusb_linux_1.0.3/bin/cyusb_linx <--excute

result : qt UI appeared and command line(No device found) appeared.

How do i connect from Linux driver?






rskv's picture
Cypress Employee
1134 posts


I am assuming that you are using the FX3 device. Can you please check the device connection notification with the help of "dmesg" command. Please check the VID and PID of the device that it is enumerating with.


Sai Krishna.

midoss's picture
2 posts

 I got same issue.  I followed instructions step by step and it worked first time and I was able to see my device. Then,I turned off my computer and few hours later, I ran Cyusb_linux and I got messgae saying "no device found".  I deleted linux ubuntu(installed on virtualbox) and installed it again and followed same steps to install cyusb linux but still I keep getting "no device found".  my device is FX2 using CY7C68013A.  Any feedback is appreciated. 


midoss's picture
2 posts

 I figured it out. I should modify cyusb.conf before following instructions in the document (make.../


Vine's picture
1 post


I have the same issue, what do you change in the .conf file ?



Log in to post new comments.