You are here

FX3LP not detecting as 3.0 | Cypress Semiconductor

FX3LP not detecting as 3.0

Summary: 2 Replies, Latest post by abhi61266 on 16 Dec 2014 01:02 AM PST
Verified Answers: 0
Last post
Log in to post new comments.
abhi61266's picture
2 posts


I have developed the board with FX3LP for Bio-matrix scanner to interface with USB3.0 port. when i connect my device it detect as USB bootloader on 2.0 and once i downlod the sample code my driver get vanished and i am not able to see any USB device. if i remove any pin of USB3.0 i.e. TX+/- or RX +/- then it detect as USB2.0 device. i route the tracks TX+/- and RX+/- with the rule diff. max is 5 mil. 

if hope even if it fails to work on 3.0 it should fall back to atleast 2.0 but it is not doing the same. 

one more thing i have used Hi-rose connector which is RA crimp type as space is constraint for me i can not use std. micro USB type B connector 

pl help


PRAG's picture
Cypress Employee
173 posts



Have you tried running the USB 3.0 electrical compliance tests on your board? Does it pass?

It might not be a good idea to use a non-standard connector.

You can create a tech support case on our website, and one of our board design engineers can review your board design files for you and provide feedback.




abhi61266's picture
2 posts

 Thanks for the reply. what is mean by USB3.0 electrical test to carry on board. i have already worked with your engineer from banglore. as per her opinion i shpiuld not use normal connector. but if i solder directly wire on connector pad is it ok? i did the same but still it won't work for 3.0 but work for 2.0 pl advice 



thanks in advance



Log in to post new comments.