You are here

FX3 USB3.0 not working? | Cypress Semiconductor

FX3 USB3.0 not working?

Summary: 2 Replies, Latest post by m.chen_1891126 on 22 Nov 2016 08:42 AM PST
Verified Answers: 0
Last post
Log in to post new comments.
m.chen_1891126's picture
User
5 posts

I have been having trouble with the SuperSpeed FX3 SDK board, and I am thinking that it might have to do with the setup/USB3.0 driver. Right now, the device will light up the green LED and then the blue LED shortly after when I plug it into my computer's USB2.0 ports (and is then recognized by the computer and shows up under Device Manager), but it only lights up the green LED when plugged into the USB3.0 ports (and is not recognized by the computer at all). Nothing comes up under Device Manager, not even an unknown device. 

I am guessing that I missed something in the 1.3.3 package setup, but I don't know what. I tried following the instructions listed in CyUSB.pdf, but I came across an error "Access denied" when trying to save the amended cyusb3.inf file with the VID and PID number (though I do not know if I needed to do this anyway, given that the VID and PID number that shows up when plugged into USB2.0 was already listed below in that file).

Does anyone have any advice? I have tried this on multiple computers with multiple SDK boards and the results are the same. I am having additional troubles with Eclipse (which I have posted about before), and I am not sure if the problems are related or not.

Thanks for the help!

 

rghe's picture
Cypress Employee
8 posts

Hi,

Could you please tell us which FX3 kit are you using? Is it CYUSBKIT-001 or CYUSBKIT-003?

Could you please make sure the connection of PMODE pins are suitable for USB boot.

m.chen_1891126's picture
User
5 posts

I am using the CYUSB3KIT-003. 

Could you tell me the exact procedure for setting up the USB boot? I am new to this and may not have done it correctly.

Thank you!

Log in to post new comments.