You are here

Flow Control with USBFS in PSoC 5 with PSoC Creator 3.1 | Cypress Semiconductor

Flow Control with USBFS in PSoC 5 with PSoC Creator 3.1

Summary: 4 Replies, Latest post by Bob Marlowe on 27 Mar 2015 04:16 AM PDT
Verified Answers: 0
Last post
Log in to post new comments.
Antonio S.'s picture
15 posts

 Hi everybody,

in my project, I'm using a Full Speed USB (USBFS) component, it works well, but with a software it doesn't. After a lot of debugging I'm sure that the software uses a Control Flow (RTS,CTS,DTR,DSR). With the UART component and a RS232 9 pin interface I joined pin 4 and 6, then 7 and 8 and I bypassed the problem. But with this component I can't do the same. I tried to use "CDC Class Request" like GET_LINE_CODING or SET_LINE_CODING but it still doesn't work. Probably I miss something. I hope someone could help me.

Thanks a lot for your time.



pvkv's picture
Cypress Employee
82 posts


You said it works well but with software it does not. Do you mean your software on PC/Mac is not working ? Can you attach your project and show a screenshot of the issue of you are facing ?


HIMA's picture
Cypress Employee
169 posts

 Hello Antonio,


For implementing RTS and DTR control signal you can toggle the respective pin based on the GetLineControl() bitmap.The 0th bit in the GET_LINE_Control using the API USB_GetLineControl(). The 0th bit will indicate the DTR status and 1st bit will indicate the RTS status.

There is now way to get the other flow control statuese vis the USB CDC class requests as of now.



Antonio S.'s picture
15 posts


thanks for the replies,

The project works well with the software made by me and by the company I work for, but when the device is used by another company, its software doesn't work, I've discovered that they use RTS on and DTR off, this seems create problem at my project.

As I wrote, I already used the USB CDC class requests and I still have communication problem. 




Although I used one of these it still not working.


user_1377889's picture
9268 posts

Do you already use the USBFS_GetLineControl() to react on RTS and DTR. Look into the datasheet, there might be a restriction with the software.



Log in to post new comments.