You are here

EZ USB suite Eclipse code parser and SDCC , type '__bit' not resolved | Cypress Semiconductor

EZ USB suite Eclipse code parser and SDCC , type '__bit' not resolved

Summary: 2 Replies, Latest post by ianh on 13 Jul 2016 08:41 AM PDT
Verified Answers: 0
Last post
Log in to post new comments.
ianh's picture
2 posts


          I have tried to compile the bulkloop demo code installed with EZ USB suite, my target is an FX2 and I have the SDCC compiler installed.  It compiles OK, but if I make any change to the code resulting in an Eclipse parser checking pass, it breaks.  For example:

(in Fx2.h)  typedef __bit        BOOL;  (Eclipse: Type '__bit' could not be resolved)

                   extern __code BYTE   USB_AutoVector; (Eclipse: Multiple markers at this line    - Line breakpoint: Fx2.h      [line: 288]    - Syntax error)

                extern __code DEVICEDSCR        DeviceDscr; (Eclipse: Syntax error)

                 extern CONFIGDSCR __xdata*   EZUSB_GetConfigDscr(BYTE ConfigIdx); (Eclipse: Syntax error)

Somehow I have managed to get EZ USB Eclipse to not recognise the peculiarities of SDCC coding.  I have tried going into the code analysis menu and turning off 'symbol is not resolved' 'type cannot be resolved' and 'field cannot be resolved', but the first time it finds a function returning Bool it reports an error and doesnt compile

../fw.c:222: syntax error: token -> 'BOOL' ; column 4
../fw.c:252: warning 112: function 'HighSpeedCapable' implicit declaration

also, it doesnt like the nop delay macro.

This is probably an elementary error,  any ideas please?






Nishant Aditya's picture
Cypress Employee
38 posts

Keil uVision platform is used to develop firmware for FX2LP. You can download the "CY3684 EZ-USB FX2LP DVK"  from the link which contains some example firmware

​You can use the application note to see how to use and build the firmware. The bulkloop is well tested and is supposed to work on Keil platform. Please check. If you still face any problem, you can create a technical support case.

ianh's picture
2 posts

Thanks,  my code is compiling OK now with SDCC & EZ USB suite (I had a mismatched curly brace, and was distracted by the spurious syntax errors) .  I guess I could use the 4K Keil eval in the earlier SDK, though it's a little dated.

Log in to post new comments.