You are here

CYUSB3035 dose not work | Cypress Semiconductor

CYUSB3035 dose not work

Summary: 2 Replies, Latest post by love_weichen_1690211 on 25 Sep 2016 06:35 PM PDT
Verified Answers: 0
Last post
Log in to post new comments.
love_weichen_1690211's picture
User
2 posts

I designed a circuit which used the cypress chip cyusb3035,but when power on,it can not connects to the computer, so it can not download the .img file.what's wrong with it?
I checked the source of 3.3V,1.5V,it's normal .And the clock is normal,but when connect to the computer it dosen't work, there is no action from the computer,what is the problom reason of this?
Need help! Thanks.

mady's picture
Cypress Employee
1022 posts

Hi,

What are the PMODE pin settings of your board? (USB Boot or I2CBoot or SPI boot etc.,). Make sure that the PMODE Settings are in tact. Also how does the device appear in the device manager? If you can see the device as "Other Device", it means the device is detected but not binded to the proper driver file. You need to do this manually. You cna contact the Tech Support if you need any assistance in this.

Regards,

-Madhu Sudhan

love_weichen_1690211's picture
User
2 posts

Hi,

The PMODE pin settings of my board are USB boot.They are in tact.When power on,there is nothing appear in the device manager.It seems that the USB chip is not working.And I checked the current of the powered circuit,the current of 3.3V is 4mA,1.2V is 32.5mA,is it OK? I checked the clock is 19.2M.Is it possible that the CYUSB3035 is broken.Is it easy to break CYUSB3035 when solder circuit boards? 

   Thanks for your help!

Log in to post new comments.