You are here

can not read from hpi port: cy7c67300 | Cypress Semiconductor

can not read from hpi port: cy7c67300

Summary: 2 Replies, Latest post by wanghaib0423 on 23 Apr 2012 11:58 PM PDT
Verified Answers: 1
Last post
Log in to post new comments.
wanghaib0423's picture
6 posts

the problem: when my Cy7 is set to bootup as HPI mode, the extern host master can not read any data from the four hpi port register but the last write data that wrtie to the hpi port registers. I dont no what's wrong, help!

when i boot the CY7 bootup as standalone, I config the GPIO as the HPI port, the extern hpi master write then read, read nothing too. but I use the qtudump, i found that the hpi write is successed. this proved the hpi write is ok. but why hpi read not work? Is there anything must be set for HPI port?

additional, I found when read the HPI port register, the data bus connect to HPI_DATA is not drived by the CY7, it hold the last data put on the bus.

prji's picture
Cypress Employee
473 posts


 Are you using EZ-HOST in Stand alone mode? EZ-host can not be connected to any host processor over HPI in stand-alone mode because when the chip is being used in stand-alone mode, one cannot have external processor acting as a Master. EZ-Host's own internal 16-bit CPU is the main processor and firmware is typically downloaded from an EEPROM. If one wants to use an external microcontroller, then you need to use the chip in co-processor mode. In co-processor mode, an external host processor drives EZ-Host  and is the main processor rather than EZ-Host's own 16-bit internal CPU.




wanghaib0423's picture
6 posts


     the problem is that,  in stand alone I config the GPIO port as HPI port, and the external master can write date to CY7' internal RAM,but cannot read anything from Cy7;in HPI mode, external master can down load firmware by hpi, and use the hpi DMA to write the IRAM,but cannot read angthing through the HPI port. In both modes, the HPI port is write able but read enable, I donnot no why? Wait for help!

   thanks so much!


Log in to post new comments.