You are here

ADRF6510 CyAPI.h link with CyAPI.lib | Cypress Semiconductor

ADRF6510 CyAPI.h link with CyAPI.lib

Summary: 4 Replies, Latest post by andi_2009_1656071 on 12 Oct 2016 01:09 AM PDT
Verified Answers: 0
Last post
Log in to post new comments.
AndyCap101's picture
6 posts



I am trying to write my own program to change the filter fc of the ADRF6510 evaluation board.

I can not seem to create an instance of CCyUSBDevice. I am using Visual Studio 2013 (64-bit) on windows 8. The driver files is, from what I can gather, the latest versions available -

EZ - USB FX3 Software Development Kit - Cypress


See the VERY simplified program below.



#include "CyAPI.h"

int main()


      CCyUSBDevice* pUSBDevice = new CCyUSBDevice(NULL);

  return 0;



The header file is correctly included and the library file is correctly linked to the project.


The error I get is:

: error LNK2019: unresolved external symbol "public: __thiscall CCyUSBDevice::CCyUSBDevice(void *,struct _GUID,int)" (??0CCyUSBDevice@@QAE@PAXU_GUID@@H@Z) referenced in function _main

USBTest.exe : fatal error LNK1120: 1 unresolved externals


Is there anything obvious I am doing wrong? Or has someone else also come across this problem (and HOPEFULLY found a solution)?


Any information would be greatly appreciated!

Many thanks,


VAVC's picture
Cypress Employee
506 posts


Please go through the link




AndyCap101's picture
6 posts

 Hello Vikas,


Thank you for the reply.


I have been through that link, added SetupAPI.lib as well as user32.lib (I have three different SetupAIP.lib files, each of 

a different size. I tried all three with no luck). This does not solve my problem.

What I understand from the error is that the constructor of the CCyUSBDevice class is not found in the 

CyAPI.lib file. Either that or I am creating the instance of the class incorrectly? All the documentation I have seen

regarding this class seems to do it as I have done it.


This class is defined as such in the CyAIP.h file:

CCyUSBDevice(HANDLE hnd = NULL, GUID guid = CYUSBDRV_GUID, BOOL bOpen = true);


Would you suggest I try an older version of the CyAPI.lib file? This would be of the FX2 version (I think).

I am rather confident that this problem has to do with 64 bit windows, but I have no idea how to approach this problem to solve it. Just to mention, I am trying to make a program with C++ and the same error occured when I used VC++ 2010.






AndyCap101's picture
6 posts

Hello Vikas,

After some scratching around I managed to find the cause of the error.


In the process of setting up the environment to write the software I copied/installed two variations of header and

library files. Both versions are from Cypress: CySuiteUSB_3_4_7_B204.exe (SuiteUSB 3.4 - USB Development tools for Visual Studio - Cypress) and cy_ssusbsuite_v1.2.3.3 (EZ - USB FX3 Software Development Kit - Cypress).


The two header files are quite different from one another, and after some copy/paste testing I managed to solve the problem. I should have just used the header and library files from  CySuiteUSB_3_4_7.


Thank you for your assistance.


andi_2009_1656071's picture
1 post


i am meet this question too,how can i do?

Log in to post new comments.