You are here

Skip a packet in AUTO-OUT mode | Cypress Semiconductor

Skip a packet in AUTO-OUT mode

Summary: 1 Reply, Latest post by RSKV on 02 Jul 2012 12:24 AM PDT
Verified Answers: 0
Last post
Log in to post new comments.
lazyWombat's picture
1 post


I setup the transfer using the auto-out mode. Everything the PC sends to the device is transferred using GPIF transfer.

Unfortunately, I need to skip the first packet, transmit 300 packets, skip 301 packet, transmit another 300 packets and so on.

In the ISR_Ep2inout I check the packet content and try to ignore it before the setting the GPIF transfer.

The code:

EP2FIFOCFG = 0x01; // manual mode


OUTPKTEND = 0X82; // skip packet


EP2FIFOCFG = 0x11; // back to auto out mode, disable PKTEND zero length send, word ops


does not work. The packet is not skipped and GPIF transfer picks it up.
If I use another code that resets FIFO (from TRM):
FIFORESET = 0x80; // activate NAK-ALL to avoid race conditions
EP2FIFOCFG = 0x01; //switching to manual mode
FIFORESET = 0x02; // Reset FIFO 2
OUTPKTEND = 0X82; // skip the packet
EP2FIFOCFG = 0x11; //switching to auto mode
FIFORESET = 0x00; //Release NAKALL

then I sometimes skip more than one packet

Is it any way to skip exactly one packet from EP2 buffer and preserve others intact?

rskv's picture
Cypress Employee
1134 posts

Meanwhile, I would recommend you to create a tech support case (MyAccount --> MyCases) regarding this. One of our engineer will look into this.


sai krishna.

Log in to post new comments.