You are here

How do I put the Keil Monitor back on the CY3684 Dev. Kit | Cypress Semiconductor

How do I put the Keil Monitor back on the CY3684 Dev. Kit

Summary: 1 Reply, Latest post by aasi on 21 May 2009 08:19 PM PDT
Verified Answers: 0
Last post
Log in to post new comments.
tpgaffn's picture
3 posts

I think I may have messed up the configuration of my 3684 dev. board by loading the CyStream code onto it to test a different thing. When I try to run the debugger now in uVision2, it does the load of the code but then I get the Window red-X Application Error that says:

The instruction at "0x00000000" referenced memory at "0x00000000". The memory could not be "read".

Click on OK to terminate the program.

Click on CANCEL to debug the program.

Did I blow away the Keil monitor when I loaded the CyStream .iic file? If so, how do I put it back on? If not, has anyone had this happen to them in using the CY3684 dev. kit?



aasi's picture
Cypress Employee
1166 posts

By default in the EEPROM the VID/PID 04B4/0082 will be stored... so as soon as you plug in the device, monitor code which is required for running keil is loaded... my understanding is that this resides in the small EEPROM... you would have written cystream.iic to large EEPROM so switching to small EEPROM should make your problem go away...

Or you can write the iic file in EEPROM image example to restore the board to its original state... or you can manually load the monitor using the Load Mon button and then try accessing the board through keil.... you can find the available monitors and their information in C:\Cypress\USB\Target\monitor

Log in to post new comments.