You are here

Bulk fifo eample with gpif will not re-enumerate successfully | Cypress Semiconductor

Bulk fifo eample with gpif will not re-enumerate successfully

Summary: 1 Reply, Latest post by aasi on 21 Sep 2011 10:11 PM PDT
Verified Answers: 0
Last post
Log in to post new comments.
hms03049's picture
5 posts

Windows 7 64  68013a 128 pin on a custom board with no eeprom
CYUSB.sys and CYUSB.inf, INC and LIB files are from CyConsole 3.4.6

The board enumerates using vid/pid 04b4 / 8613 as "Cypress EZ-USB FX2LP - EEPROM missing"

A old bulk/fifo with gpif example builds and successfully downloads using Keil UV2 and EZ-USB Interface (

Once downloaded it will re-enumerate showing "Cypress USB Generic Driver " in the Device Manager" but is stopped with a code10 error making it unavailable to CyConsole etc.

It worked with  with the previous cyusb.sys driver (04B4 / 1004) in XP/32 which does not work with W-7 / 64

I've spent a lot of time searching for a similar post and missed it if this is one. Any suggestions will be appreciated.

Here are snippets from the Keil UV2 build and inf files:

      dw   0B404H               ; Vendor ID
      dw   01486H               ; Product ID
   // dw   01386H               ; Product ID    I have tried all 3 including pid 1004

;for x64 platforms
;for x64 platforms
%VID_04B4&PID_8613.DeviceDesc%=CyUsb, USB\VID_04B4&PID_8613
%VID_04B4&PID_8614.DeviceDesc%=CyUsb, USB\VID_04B4&PID_8614

[Strings];for x64 platforms
VID_04B4&PID_8613.DeviceDesc="Cypress EZ-USB FX2LP - EEPROM missing"
VID_04B4&PID_8614.DeviceDesc="Cypress USB Generic Driver ("

aasi's picture
Cypress Employee
1166 posts

If you right click the device in device manager then do a update driver and point to the location of this inf file what is the error message you get??



Log in to post new comments.