You are here

CY7C65213-32LTXI in CY_TYPE_MFG mode | Cypress Semiconductor

CY7C65213-32LTXI in CY_TYPE_MFG mode

Summary: 3 Replies, Latest post by raphael.schroeder_1509696 on 11 Dec 2015 02:02 AM PST
Verified Answers: 0
Last post
Log in to post new comments.

Hello everybody,

i have a CY7C65213-32LTXI chip on my custom board.

It should work as a UART interface,

but when i connect to it it says it is in  CY_TYPE_MFG mode and no UART SetFunction or even GetConfig will work.


- I tried to program it with "USB Serial Configuration Utility.exe" but it wont change the Device type...

- Do i need to program the Flash or what?

- even if, where can i get a binary to flash??

- or is it just the wrong driver???


tnx in advance

Haneesh's picture
Cypress Employee
18 posts



Can you create a tech support case at with screenshot of  "USB Serial Configuration Utility.exe" when device is connected?







Ok, heres the screens from the Config tool. This is using a little Evalboard not the custom boar but i have the same Error with the API that i cannot get the uart config or even set.

many tnx in advance



Does it work now?

Dammit spam filter..

Log in to post new comments.