You are here

FX3 firmware release build doesn't work anymore | Cypress Semiconductor

FX3 firmware release build doesn't work anymore

Summary: 1 Reply, Latest post by Madhu Sudhan on 22 May 2016 09:24 PM PDT
Verified Answers: 0
Last post
Log in to post new comments.
Fred Xu's picture
3 posts

We have been using the debug build for the development, test and bug fix and programming  the release build into the I2C.  For over a year we never had any issue with release build. Recently we found our system works fine with the emulator and debug build but it doesn't work with the release build. So we programmed a debug build into the I2C and the system works. 

After some experiments we found the release build causes some API call to return NOT SUCCESS which never happened in the debug build. We have tried to add some I/O outputs to track down the failed API call. However, the failed API call changes when more I/O output code is added. It looks the release build is not stable. We have tried to set the optimization level to None but that didn't help.

A few weeks we found the same project, same source code the release build compiled with ezUsbSuite version 1.3.1 works but not with version 1.3.3. Now after adding more code the release build compiled with version 1.3.1 stopped working too. 

What could cause this? How can we make the release build work? 


mady's picture
Cypress Employee
963 posts

Hi Fred,

Our engineers are working on this in the Tech Support case you created. We will keep you updated over the case.


- Madhu Sudhan

Log in to post new comments.