You are here

fx3 enumerate as UNKOWN DEVICE, driver don't install | Cypress Semiconductor

fx3 enumerate as UNKOWN DEVICE, driver don't install

Summary: 3 Replies, Latest post by Paul Claessen on 25 Oct 2015 01:45 PM PDT
Verified Answers: 0
Last post
Log in to post new comments.
Paulsons's picture
1 post

I've designed my own FPGA board using Cypress CYUSB3014 as the USB controller, and of course, I had been following the hardware design guidelines. But the problem is, when I config the PMODE[2:0] pins as F11(USB boot mode) and connect the board to PC, it enumerated as UNKNOWN DEVICE. And after I checked the windows device manager to try to install the driver, it responded as "windows could not find driver software for your device".

I've installed the EZ-USB FX3 SDK, the driver is supposed to be in the direction "C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\driver\bin\", but I've tried to install it on both win7 and win8, the responses : "windows could not find driver ...". And of course, when I open the USB Control Center, nothing shows out.

I tested the board, the chip is powered up, and the clock source(19.2MHz oscillator ASEMB-19.2MHZ) is working fine. I connected the oscillator output to the CLKIN pin, config FSLC[2:0] pins as 100. The chip should be working fine.

I've tried every solution I can find online, but nothing better happened. I'm really exhausted now. Did anyone else come across this kind of problem? What's your solution?

Simon Morrell's picture
4 posts

Did you find a solution to this problem?

I have exactly the same issue. My prototypes fail enumeration. All power supplies and communications connections are good. Like you, I am using an external oscillator (ASEMB-19.2MHZ) connected to the CLKIN input. I have also configured the FSCLK[2:0] pins to be 100.

Perhaps there is a problem using an external oscillator instead of a crystal. Can anyone provide any input here please?

Naz's picture
12 posts

My fast enumeration usb setup callback does not handle host requests or usb events properly (yet). So, every time I do something wrong on the host side, my device starts being unknown to the PC. The only way, I found, to get it recognized again was to restart the PC.  

Paul Claessen's picture
24 posts

If any of the above posters found a solution, could they share it with us?

If no solution has been found: did you make sure your PMODE[2-0] pins were configured correctly for the proper boot operation?


Log in to post new comments.