You are here

FX3 Composite device (UVC + usb-uart) can not recognition in linux | Cypress Semiconductor

FX3 Composite device (UVC + usb-uart) can not recognition in linux

Summary: 8 Replies, Latest post by hank.fang.usa_1859146 on 09 Oct 2016 11:15 AM PDT
Verified Answers: 0
Last post
Log in to post new comments.
Wei Liu's picture
User
6 posts

HI,there.

the composite device(UVC+usb-uart  ----they are all use IADs) is work in windows,but when i use it in linux ,it just only one device can work.

dmesg | tail -20

[ 3742.954606] usb 2-1.1: New USB device found, idVendor=04b4, idProduct=00f8
[ 3742.954611] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 3742.954614] usb 2-1.1: Product: FX3
[ 3742.954616] usb 2-1.1: Manufacturer: Cypress
[ 3742.956050] uvcvideo: Found UVC 1.00 device FX3 (04b4:00f8)
[ 3742.957704] input: FX3 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/input/input16
[ 3742.957965] cdc_acm 2-1.1:1.2: This device cannot do calls on its own. It is not a modem.
[ 3742.957974] cdc_acm: probe of 2-1.1:1.2 failed with error -22

hope someone can help me to solve my doubt.

Many thanks in advance!

 

Attachments: 
mady's picture
Cypress Employee
1056 posts

Hi,

In "Interface Number of Data Class interface" field of the Call management function descriptor, you need to specify the number of data interface descriptor, which is 0x03 in your case. But it has bee specified as 1.

Please refer the attached firmware as a reference for UVC + USBUART Interface,

Regards,

- Madhu Sudhan

Wei Liu's picture
User
6 posts

Hi,

thanks a lot.i modified my project as you suggested,but it does not work in linux.

there is my composite device FX3 project,if you have enough time,i hope you can solve my doubt,thanks!

evgeniy.mironets_1479661's picture
User
17 posts

Hi, Wei Liu. I'm novice here. Now I try to make composite device.

Can you share (or send me) your project? If you want of course.

Thank you in advance and regards!

Wei Liu's picture
User
6 posts

Hi,there is the FX3 project,i hope it will help you.

this project is UVC + USB-UART composite device,it is fine in windows,but it has a bug in linux system(test in ubuntu 14.04),only one device can be detect in linux.

if you have free time,i also hope you can help me to solve my doubt,thanks a lot!

 

Dominik Honegger's picture
User
1 post

Hi,

I managed to access the serial port in Linux:

- change product id in usb descriptor to 0xF139 :        < 0x39,0xF1,                      /* Product ID */ >

- use modprobe to bind the usbserial driver to the device <sudo modprobe usbserial vendor=0x04B4 product=0xF139

- the device appears now as /dev/ttyUSB0

 

 

Wei Liu's picture
User
6 posts

Hi,

it works when i do what you tell me.thanks a lot.谢谢!

hank.fang.usa_1859146's picture
User
1 post

HI, Liu Wei: other than changing the product id to 0xF139, did you use some other tricks to make it working? I followed this post but the UART is still not working(not showing /dev/ttyUSB?) in linux (ubutun 14.04). /thanks!

rabergw_1682456's picture
User
1 post

Hi,

I have looked at your project, I hope that was okay. 

I understand that you have set the UART as a loopback function, Im interested in writing and receiving from the UART pins on the device. What settings can I change to get that function if I may ask?

Regards,

Wilhelm Rabergh

Log in to post new comments.