You are here

CYUSB.dll does not recognize forced-to-full-speed EZUSB FX3? | Cypress Semiconductor

CYUSB.dll does not recognize forced-to-full-speed EZUSB FX3?

Summary: 2 Replies, Latest post by Takuya.Yamauchi_1604786 on 10 Mar 2016 05:41 AM PST
Verified Answers: 0
Last post
Log in to post new comments.

Related thread:

I would like to reduce the data rate of EZUSB FX3 down to 12 Mbps and application software is constructed on CYUSB.dll for .NET.

I tried to force FX3 to full speed or 12 Mbps mode, and I added CyU3PUsbForceFullSpeed(CyTrue) to the example 'cyfxbulkstream' or 'USBBulkStreams', along with the related thread above. The source code now looks like below:

/* This function initializes the USB Module, sets the enumeration descriptors.
 * This function does not start the bulk streaming and this is done only when
 * SET_CONF event is received. */
CyFxBulkStreamsApplnInit (void)
    CyU3PReturnStatus_t apiRetStatus = CY_U3P_SUCCESS;


    apiRetStatus = CyU3PUsbForceFullSpeed(CyTrue);
    if (apiRetStatus != CY_U3P_SUCCESS)
        CyU3PGpioSetValue(54, CyFalse);

    /* Connect the USB Pins with super speed operation enabled. */
    //apiRetStatus = CyU3PConnectState(CyTrue, CyTrue);
    apiRetStatus = CyU3PConnectState(CyTrue, CyFalse);
    if (apiRetStatus != CY_U3P_SUCCESS)
        CyU3PDebugPrint (4, "USB Connect failed, Error code = %d\n", apiRetStatus);

I tried to check the full-speed-only firmware on C# Blukloop and C++ Streamer which were accompanied with EZUSB FX3 SDK. C# one does not recognize the full-speed-only device, C++ one looks to see it as shown in the two attached screen captures. I could see the full-speed-only device on Windows Device Manager. I also tried to watch the device from CYUSB.dll .NET with C#, but it did not recognize the full speed only device. The firmware was downloaded with Cypress Control Center, which did not recognize the full speed only device after downloading. Version of Windows is also attached. I use version 1.3.3 of EZUSB FX3 SDK.


Nishant Aditya's picture
Cypress Employee
38 posts



I check this on Win 7 professional 64 bit. In my case the C# bulkloop application works properly (please see the attached). 

I have attached the firmware which I have tested. Please check ! You can also try on a different host and check if the host in causing problem in Fullspeed mode.



I tried it on USB 2.0 port and it works. It does not work on USB 3.0 port... I had tried with USB 3.0 port yesterday. It is my laptop's problem, isn't it? My firmware also works well. Anyway, thank you for quick replying.



Log in to post new comments.