You are here

CYUSB3KIT-003 noise generation | Cypress Semiconductor

CYUSB3KIT-003 noise generation

Summary: 1 Reply, Latest post by odissey1 on 12 Nov 2016 08:09 AM PST
Verified Answers: 0
Last post
Log in to post new comments.
MR
MR's picture
User
5 posts

Hi,

I used CYUSB3KIT-003 board in one my designs , it has an amplifier to amplify the antenna analog signal , an ADC to convert the signal to digital and an FPGA for managing data and send it to PC through 

CYUSB3KIT-003 board. my board and CYUSB3KIT-003 board connected through the two 2x20 connector (headers on usb3kit and pins on fpga board part). i send fpga managed data with a 100 MHz Clock (i use the asynchronous FIFO example provided in the package ) and with the rate of 260 MBytes/s.
now , the problem is that the long tracks that connects fpga outputs to the cypress usb3 chip on the CYUSB3KIT-003 (and of course the connectors) generate a huge amount of noise, and even without any amplification you can see the noise generated by the CYUSB3KIT-003 board input digital signals on the data captured by the ADC , very clearly (they have the amplitude of more than tens of milivolts ).
My question is that how i can get rid of them? (preferably without having to design a new board with the usb3 chip mounting on it )
can i resolve the problem and also use the CYUSB3KIT-003 board in the design ?

user_342122993's picture
User
580 posts

My guess 'antenna' and 'long wires' don't go along, and standard analog troubleshooting techniques should apply:
1. Try shorten 2x20 cables
2. Try putting ferrite beads on them
3. Try shielding them with metal foil
4. Check if noise propagates through power lines to ADC and decouple with caps
Etc.

Log in to post new comments.