You are here

PSoC Designer Halts when Building | Cypress Semiconductor

PSoC Designer Halts when Building

Summary: 6 Replies, Latest post by leopaom on 03 Jul 2015 03:00 PM PDT
Verified Answers: 0
Last post
Log in to post new comments.
JWH's picture
2 posts

I am using PSoc Designer 5.1 on a CY8C29466 project.

Several times, after I clicked 'Build', the message 'Saving the configuration to the file...' appeared at lower left .... and stayed there. Any functions that do not involve the 'Build' seem to work fine: I can save, edit, compile and navigate around.

But the build never finishes, by which, I mean that the Programmer always complains that a new .hex file does not exist.)

Also, PSoC cannot be closed and even the task manager has trouble (takes about five minutes) ending the program.

Any illlumination on this?


Wade Hassler

rtcy's picture
Cypress Employee
112 posts


We need some additional information from you and we should meake this issue an official support case.

When signed in, please follow this link

Thank you that you work with us to find a solution.


raimoo's picture
4 posts

Is there any solution to this problem?  I have the same issue with one c27443 project. Some other projects build just fine. Maybe some corrupted file? I'm using 5.3 designer.

There is a warning saying :

CAUTION lib/psocconfig.asm is older than PSoCConfig.xml or missing

CAUTION you may need to generate source in PSoC Designer

when I use Rebuild in the menu.

Any other way than starting from scratch with this project ?

br raimo

raimoo's picture
4 posts

Hi again

The problem resolved by copying the whole project in a new folder by "save workspace as..."  option. This is not a very pleasant feature though.



user_1377889's picture
9284 posts

Very rarely I had corrupted project files, mostly when I tried opening them with a different version of the software. The "Archive Project" option which is new in Designer 5.3 is a feature I have waited for a long time, helping me to keep my project-folders small and clean. Nice to see -as you reported- that it can be used to refresh corrupted files as well.



la23ng's picture
1 post

 This is a me too. I have seen the same problem when generating the the sample capsense project CY3280_20x66_Project1 after some small changes.

Fortunately, saving the workspace to a different place resolved the issue for me.

(I'm a complete newbie, so this was somewhat disconcerting)

leopaom's picture
1 post

 Rebuild the project that it will work. I have got the same problem and this worked for me.

Log in to post new comments.