You are here

Error while building | Cypress Semiconductor

Error while building

Summary: 5 Replies, Latest post by kdiggity on 16 Apr 2012 02:35 PM PDT
Verified Answers: 0
Last post
Log in to post new comments.
user_125259184's picture
2 posts

I have two machines running Cypress Designer.  My main machine is running Cypress Designer 5.1 build 1875 and I wanted to ensure that the new Cypress updates didn't break anything so I created a new XP machine and installed Cypress Deisnger 5.1 and updated it to build 2110.  The only other difference between these XP machines is that the new XP machine has all the current Windows updates while the older machine does not.

I opened a known good designer app, that was working on my old machine, on my new machine and pressed F6 (generate/build).  I get an error that says "psocmakemake.exe has encountered a problem and needs to close."   I have the option of "Send Error Report" or "Don't Send" (to Microsoft I presume).  After pressing "Don't Send" the Output frame shows:

Starting MAKE...
C:\PROGRA~1\Cypress\PSOCDE~1\5.1\Common\CYPRES~3\tools\make: *** [makemake] Error -1073741819
CAUTION there are no library files
It appears to have failed to compile fully as the Microsoft error window must abort the process.
Any idea on how I fix this?
user_125259184's picture
2 posts

19 views and no one has any suggestions?  I'm guessing this is a first time error.  Should I just uninstall Cypress all together and reinstall the older version?

rtcy's picture
Cypress Employee
112 posts


this appears to be more a one of a kind issue. If other forum members have not experienced the same issue it is difficult to respond.

Did you already file a support case?

Highly recommended!

You want to go here

And then "Create a case" in the lower right hand corner of the screen.


SidneyCombi's picture
1 post

 I am seeing the same problem. Have you managed to resolve the problem and if so how?

I created a case with Cypress but haven't had a response.

Stub for 6137682's picture
9 posts


It's troubling to hear that you have created a support case and not received a response. I certainly hope that is no longer the case. If it is, can you please give me your case number so I can chase down what happened here?

Assuming our support team has been in contact with you, were they able to resolve your difficulty?

Paul Clark



kdiggity's picture
1 post

I have also encountered this error. It seems to be an issue with the compiler (but I am not sure yet). I am running the hi tech c compiler v9.60 on PSoC Designer 5.2 (build 2401).  I have tried the following:

  • I tried a different program and the program compiled/built without issues
  • I tried a different program but one with the same chip and no issues
  • I tried an earlier rev of the program and observed issues.
  • I tried the imaginecraft c compiler and did not get windows error.



Log in to post new comments.