You are here

Why is a component update required on a brand new version of Creator? Fancontroller | Cypress Semiconductor

Why is a component update required on a brand new version of Creator? Fancontroller

Summary: 1 Reply, Latest post by Bob Marlowe on 27 Jul 2012 03:11 AM PDT
Verified Answers: 0
Last post
Log in to post new comments.
user_66897694's picture
19 posts

First of all, this could definitely be a user issue but here is what happened:

I opened Creator 2.1 and 2.0 at the same time using 2 monitors and searching for differences.

There are not many but the most upfront visible changes are a so called document manager and sample designs which can be used instead of an empty screen when I create a new project.
I selected the Design04 with Fan Contoller and it asked for a component update when I was using Creator 2.1. Indeed, my Fan Controller component was V1.20 while there is a new version 2.0 available.

Here is the question: 

Can it happen that the new components are overwritten by the old ones when both versions of Creator are open at the same time?

Anybody else experienced strange behavior while having 2 versions of Creator open?

Not a big deal for me right now but I would like to avoid this in future.

user_1377889's picture
9294 posts

There comes a list of differences between the two versions Creator 2.0 and 2.1, so it can be much easier to follow up all the changes where some of them are not visible in a menu or tab at first sight.

2.0 and 2.1 are co-existent, that means you can use both at the same time, but you should avoid accessing the same project with different versions because the internal structure of a project differs. Having saved a project under 2.1 it may not be opened again with 2.0 although there has a backup been created (when opened with 2.1) from which you may re-start with 2.0.

Updating components for a project overwrites the PROJECT's components, not those in your component list.

Not updating components will leave your project as-it-is with the older versions.

Bit I would always suggest to use the latest version of a component, sometimes there are nasty bugs removed. Have a look into the according datasheets, there (at the very end) is a list of changes made so far.



Log in to post new comments.