You are here

PSoC Programmer COM-object failed to start! - trn.M0004 (PSoC Creator) | Cypress Semiconductor

PSoC Programmer COM-object failed to start! - trn.M0004 (PSoC Creator)

Summary: 9 Replies, Latest post by JOBIN on 02 Nov 2016 02:59 AM PDT
Verified Answers: 2
Last post
Log in to post new comments.
info_1755911's picture
User
5 posts

I installed PSoC Creator3.3 and PSoC Programmer. When I start PSoC Programmer then I get the message "PSoC Programmer com-object failed to start! ....".
I read already all the existing tasks regarding to this issue, I de-installed / re-installed the Creator and the Programmer, I deleted the drivers, I re-installed the drivers, I re-installed the Creator and the Programmer with updated versions, I installed it as "typical" and than as "complete", ....and so on. 

The result is that the Programmer gives me the message "PSoC Programmer com-object failed to start! ...." when I start it, and the Creator gives me the error-message trn.M0004 "PSoC Programmer is not installed on your coumputer system. ......", when I start it.

I installed the creator on a different system in a virtual machine and there it worked. But I want to get it running on my PC-System (Win-XP, SP3) !!!!!!

Please help me, ...I'm at my wits' end...

Regards,
Thomas

user_242978793's picture
User
1029 posts

Psoc Creator 3.3 will not work on XP even if you are using SP 3. Upgrade to windows 7 or Windows 10.

info_1755911's picture
User
5 posts

Thanks for your rapid answer. By the way, ...in a virtual XP machine it works. Because of the poor environment (RAM) of this VM computer unfortunately it works not stable.

In a first step I want to get familiar with the BLE topic and I only have Win-XP here. So I don't want to by an extra Win7-OS for this.  

Which versions are the latest which are working with Windows XP? I should get the version numbers for the PSoC-Creator, the PSoC-Programmer and the CySmart which are working with XP because I do not yet have a Win7 here at my place.

Best Regards,

Thomas

jobi's picture
Cypress Employee
74 posts

Hello,

You can find the supported OS in the PSoC Creator release notes:

http://www.cypress.com/file/290261/download    Installation - Operating System

You can see Windows XP SP3 (32-bit supported)  as a standalone, for VM it is different.

Thanks

JOBIN GT

info_1755911's picture
User
5 posts

Hi,

it seems that PSoC-Creator 3.3 is running but that the PSoC-Programmer generates these problems. But in the release notes of PSoC-Programmer ( http://www.cypress.com/file/46506/download , on page 7) you can see that it also should work with XP. So why do I get such error messages when using XP?

I saw a remark that PSoC-Programmer should be "preinstalled" to PSoC-Creator. Is this strongly necessary or just recommended and not forded to be done.

I ordered a Win7 Computer for tests to check it additionally with Win7 but I want to get it running with XP.

Regards,

Thomas

mdl's picture
Cypress Employee
37 posts

I would try uninstalling PSoC Programmer, then re-installing from cypress.com/programmer.

info_1755911's picture
User
5 posts

I already re-installed PSoC-PRogrammer (with using CCleaner for registry cleaning after uninstalling). I already re-installed PSoC-Creator (with using CCleaner for registry cleaning after uninstalling). ....see my first entry in this forum.

I downloaded already the nearest latest versions of all of the software which I (try to) use (Programmer, Creator ...and CySmart ....versions from about 2 weeks ago).

Maybe there is some important hidden entry in the registry which the CCleaner did not delete?

Regards,
Thomas

jobi's picture
Cypress Employee
74 posts
info_1755911's picture
User
5 posts

Thanks Jobin,

to be sure that really everything is removed I did it this way, ...I removed (de-installed with Cypress-Manager) the complete cypress tools (Creator, Programmer, Manager, ...etc.). Then I started the "RegistryRepairApplication.exe" and removed ALL entries. After this I started CCleaner. So there should be nothing  left from any cypress programs. Then I restarted the PC. After restart I installed only PSoC-Programmer, then I did a restart of the PC. After this restart I tried to start PSoC-Programmer. The result was that the same PSoC-Programmer-Error-Message window appears as before (see attachment PSoC-Prog_Err_COM.jpg).

After this I installed PSoC-Creator again but the result did not change (same error message window, ...see attachment, ...PSoC-Creator_Err_no-Prog.jpg).

Regards,
Thomas

jobi's picture
Cypress Employee
74 posts

Hi,

Can you try:

Open Command Prompt in Administrator mode. (Right click and select ‘Run as administrator’)
Change Directory to “C:\Program Files (x86)\Cypress\Programmer”
Run PSoCProgrammerCOM.exe /unregserver
Run PSoCProgrammerCOM.exe /regserver

 

Thanks

JOBIN GT

Log in to post new comments.