You are here

PSoC creator not compiling all source files. | Cypress Semiconductor

PSoC creator not compiling all source files.

Summary: 5 Replies, Latest post by fidel17_1899026 on 03 Nov 2016 01:01 AM PDT
Verified Answers: 2
Last post
Log in to post new comments.
fidel17_1899026's picture
User
7 posts

Hi 

 

I moved source files in my projects to folders to clean/make project more clear.

After this, few files are not being compiled, I am geting error:

 

arm-none-eabi-gcc.exe: error: .\CortexM0\ARM_GCC_493\Debug\sample_file.o: No such file or directory

 

It happens after Clean and built. When I compile those .c filest manualy from list (right mouse -> Compile_file) then .o files are generated.

 

But again, cleaning deletes them. 

 

What happened?

user_1377889's picture
User
9572 posts

You have to set the path to your source files in project settings, include directories.

 

Bob

fidel17_1899026's picture
User
7 posts

How? I cannot find this. I have folder path in include.

What is more, not all files get this error. Only few. 

 

SOLVED:

Changing project name helped, seems that there is some bug. 

 

fidel17_1899026's picture
User
7 posts

Again, with different file.

jobi's picture
Cypress Employee
74 posts

Hi,

Can you post the project here?

Thanks

JOBIN GT

fidel17_1899026's picture
User
7 posts

Sorry, I can not. 

I found other fix, seems that when you move files on HDD and then remove and add them again in PSoC Creator not all file path entries in LUXWIN_CPRL.cyprj.(your name) file are updated. I fixed them by hand and now everything seems to be ok. 

Log in to post new comments.