You are here

PSoC Creator 3.0/3.3 not exporting to uVision | Cypress Semiconductor

PSoC Creator 3.0/3.3 not exporting to uVision

Summary: 3 Replies, Latest post by stephen.goodman_1680746 on 18 Aug 2016 01:07 AM PDT
Verified Answers: 1
Last post
Log in to post new comments.

I am trying to export a project from PSoC Creator to uVision and I keep getting failures.  I tried with version 3.3 and got the error:

"The export has failed. Keil uVision was unable to write to the uVision project target projectName.uvproj. This file may be open in another instance of uVision or marked readonly. Close uVision  ot make the project file writable, then try to export again."

There is no uVision instances open and the projectName.uvproj file does not even exist to have any attributes associated with it.  When I clicked finish at the end of the wizard I ticked the "Open containing folder" tick box but it just opened my user folder with "My Documents" highlighted.

I thought it might be a permissions thing (even though I am not working in any special folders and permissions shouldn't be an issue), so I tried running PSoC Creator with admin privileges.  This reports that the uVision project was created successfully.  I made sure that "Open in uVision" and "Open containing folder" were ticked and clicked finish but the uVision project doesn't open and, like above, my user folder is opened with "My Documents" highlighted.  I searched for any trace of the uVision project but it has not been created even though the wizard reported that it has.

I then tried version 3.0 SP2 I got the error:

"The export has failed. uVision failed to create a project from the Chip Export Mode xml for project "projectName"."

Opening the containing folder brought up the user folder with "My Documents" highlighted. Again I tried running PSoC Creator with admin privileges and I got the same result as version 3.3.  No project was created and"My Documents" in my user folder was highlighted but the wizard reported success.

When I used version 2.1 SP1 the project I created had no problems being exported to uVision.

I am running on Windows 7 Professional SP1 64 bit.

jobi's picture
Cypress Employee
67 posts

Hello Stephen,

We are working on this issue via technical support case, we will update the resolution here as well.



For anyone else who is having the same issue here is the latest from Cypress.

We had confirmed with ARM that there is an issue existing, which blocks the import process from PSoC Creator to µVision V5.20.0.0.

They had confirmed that the issue will be addressed in the next version v5.21, which will be released by August as per the plan.

Until then you need to use lower version of uvision. The issue is there for version v5.16 to v5.20.

I can confirm that the v5.21 update for uVision has solved this issue.

Log in to post new comments.