You are here

Programming requires I select the device every time | Cypress Semiconductor

Programming requires I select the device every time

Summary: 7 Replies, Latest post by JOBIN on 22 Nov 2016 01:54 AM PST
Verified Answers: 2
Last post
Log in to post new comments.
bnichols_1926576's picture
User
3 posts

Hello,

I am using PSOC Creator 3.3 with the CY8Ckit-050. I believe some setting or something has gotten changed but I cannot figure it out. The problem is: When I used to click the program button PSoC would program the device plugged into my computer without any further intervention. However, now when I click the button it brings up the "Select Debug Target" window and I have to press "Port Acquire" and then connect and finally the Ok button for programming to happen. This is a bit of a nuisance because I am cosntantly programming the device while I am developing my program.

Have I changed a setting somewhere? Honestly, I don't believe this to be the case as I have not been mucking around in any settings windows.

Thanks for any help.

user_1377889's picture
User
9572 posts

Welcome in the forum.

I do not know if this cures your issue, but I would suggest you to use latest Creator version which is 4.0.

 

Bob

bnichols_1926576's picture
User
3 posts

Thanks, I tried your suggestion and installed version 4.0 but the same behavior persists.

user_1377889's picture
User
9572 posts

I would suggest you to get in contact with Cypress directly: At top of this page select "Design support -> Create a Support Case" and ask your question. You will be helped by a Cypress engineer.

Bob

ANKS's picture
Cypress Employee
88 posts

In the System Tab,have you set the Debug select as SWD or not

bnichols_1926576's picture
User
3 posts

I wanted to use the pins and set it to GPIO.

ANKS's picture
Cypress Employee
88 posts

Thus,as you have set in the System Tab, Debug select as GPIO,you are encountering this phenomenon.

jobi's picture
Cypress Employee
74 posts

Hello Brian,
[From support case]This is because the Debug Select is set to GPIO. When GPIO is selected debug pins like P1_0,P1_1 will act as SWD only for a certain time after the reset [this will become normal GPIO]. So to acquire the device the PSoC Creator has to send RESET signal. This is why you need to acquire all the time you try to program. If you select the Debug Select as SWD you can see the issue is resolved. 

Thanks

JOBIN GT

Log in to post new comments.