You are here

Error Using One Channel of ADC SAR | Cypress Semiconductor

Error Using One Channel of ADC SAR

Summary: 4 Replies, Latest post by Ryan.Corbin_1842186 on 10 Nov 2016 08:43 AM PST
Verified Answers: 1
Last post
Log in to post new comments.
Ryan.Corbin_1842186's picture
User
3 posts

I'm working on a PSoC 4 project where I need to use the ADC for one signal. However, I get the following error during the analog placement step of the build: "Net 'Net_575' is connected to an analog mux but is not connected to another component." I have noticed that Net_575 does not exist in my schematic. I also get warnings about the analog terminals on the ADC being unconnected. The build is successful if I connect analog pins to every channel. 

I have disabled all the other channels except for the one I want to use. Is there another setting that needs to change in order to only use one ADC channel? I'm using PSoC Creator  3.3 CP3 (3.3.0.9604) and the ADC_SAR_SEQ_P4 component's version is 1.10.

user_1377889's picture
User
9583 posts

Welcome in the forum, Ryan.

Can you please post your complete project, so that we all can have a look at all of your settings. To do so, use
Creator->File->Create Workspace Bundle (minimal)
and attach the resulting file.

 

Bob

Ryan.Corbin_1842186's picture
User
3 posts

Thanks for your quick response.

I have attached a sample project that exhibits the same issue as my project.

user_1377889's picture
User
9583 posts

Just set the number of channels for the ADC (on the channels tab) to 1 (one) and reconnect the input pin.

 

Bob

Ryan.Corbin_1842186's picture
User
3 posts

I knew that it was something simple that I was overlooking. Thanks!

Log in to post new comments.