There is no constant defined for Shiftreg_RET_FIFO_NOT_FULL like shown on page 10
forwarded your findings to the component documentation team.
Thanks for pointing this out. You are correct the value that will be returned by the component is RET_FIFO_NOT_EMPTY. I'm not happy with the name of that define and I've asked to keep it for backwards compatibility, but to add and document this value as RET_FIFO_PARTIAL. This value does not mean that the FIFO is NOT_EMPTY or NOT_FULL. This value actually is returned when the FIFO is partially full (ie. neither FULL nor EMPTY).
This is one of the few places where a returned value is preponed by "RET_" . Why not call it just "FIFO_PARTIALLY_FULL" and rename the other defines similarly and according to other component which use a FIFO. That could be made system-wide.