You are here

Customization of keyboard shortcuts lost in PSoC Creator 3.3 SP2 | Cypress Semiconductor

Customization of keyboard shortcuts lost in PSoC Creator 3.3 SP2

Summary: 8 Replies, Latest post by ANKS on 10 Nov 2016 10:41 PM PST
Verified Answers: 1
Last post
Log in to post new comments.

Hi,

I customize some keyboard shortcuts in PSoC Creator 3.3 SP2 (see here). After a while (not in the same session), PSoC Creator will lose my customizations (i.e. I have to assign shortcut keys again). If I recall correctly, I also encountered this problem in PSoC Creator 3.2. Has anyone encountered this problem before? 

Thanks,

Fred

user_1377889's picture
User
9596 posts

Welcome in the forum, Fred.

As far as I remember there was nothing similar posted yet. Can you associate the lost of the definitions with any OS action you did (File cleaning, registry change etc.)

 

Bob

Hi Bob, thanks for your reply.

I don't really have actions associated with it. It happens when I'm in PSoC Creator for a while and I close/reopen the program (e.g. I open it one day, leave it open until the next day, and on the next day I close/reopen PSoC Creator). PSoC Creator doesn't do this after every close/reopen sequence. Also, I've just tested after a reboot of my computer and my shortcuts were still working (i.e. PSoC Creator didn't lose my customization).

I think it's worth noting that I'm running PSoC Creator on a Bootcamp partition of my MacBook Pro, although I don't know if that could affect my problem. I'm also running this on Windows 10.

Fred

 

Edit: I've resubmitted this comment as a reply to your answer instead of a standalone comment.

Hi Bob,

Yesterday, I turned off my computer and this morning, PSoC Creator still has my configuration. I'm beginning to think that my problem occurs when my computer goes to sleep when PSoC Creator is open. I will need to test this further.

If that is the case, do you have an idea as to why this happens?

 

Thank you,

Fred

Hi Bob,

I haven't heard any news since the last time I posted. Do you have any clues as to why this occurs to me?

Fred

user_1377889's picture
User
9596 posts

No further clue. Sounds a bit like an OS issue.

 

Bob

457768148_1915951's picture
User
1 post

Hi:

The CYUSB3KET003's LED2 stays ON whatever it connected to a USB2.0 or USB3.0 host port. I don't know why,can you help me? Thanks.

user_1377889's picture
User
9596 posts

How is your question related to the keyboard shortcut settings?

 

Bob

ANKS's picture
Cypress Employee
89 posts

This issue is not reproducible,I tried to create a Shortcut in PC4.0 with PC having Windows10,put the system on sleep(while PC4.0 was open) .

After the system woke up from sleep ,Shorcut settings was still there.

Log in to post new comments.