You are here

Locked out of editing source file | Cypress Semiconductor

Locked out of editing source file

Summary: 1 Reply, Latest post by odissey1 on 13 Nov 2016 09:30 PM PST
Verified Answers: 1
Last post
Log in to post new comments.
millsj2_1948266's picture
User
1 post

Hi,

I've recently started learning how to use PSOC Creator, so this may be an easy fix. I randomly cannot edit my main.c file, or any new text files I create. Not that I would want to, but I also tried editing the Cypress generated source code for my project and cannot edit that either. If I edit my main.c file in another editor and save it, the text file in PSOC Creator is updated. I've tried restarting the program, closing and reopening the file, etc. 

I believe I am using the most updated version of Creator. Did I accidentally activate a type of locking feature?

Thanks

Jesse

user_342122993's picture
User
582 posts

millsj2,
If you trying to edit existing Cypress files (which are normally locked), select project and save it under different name first. If there are lock icons next to file names, those files are locked.
Do not edit generated files as they are being automatically re-generated each time project is rebuilt.

Log in to post new comments.