You are here

PSoC 5LP and MiniProg3 | Cypress Semiconductor

PSoC 5LP and MiniProg3

Summary: 6 Replies, Latest post by JOBIN on 17 Jan 2017 04:41 AM PST
Verified Answers: 3
Last post
Log in to post new comments.
vijayr.acns_1628096's picture
User
35 posts

Hi All,

I have a hardware board in which my controller CY8C5868AXI-LP035 is mounted. I also have the 10 pin SWD/JTAG connector connected to the controller. I am using MiniProg3 to program my controller. I have with me PSoC Creator 4 and PSoC Programmer software. I created a blank project in PSoC Creator just to verify if I am able to program my controller (this is the first time I am using MiniProg3 to program my device and hence the blank project). I tried programming using both the software and I am not able to succeed.

Setting in PSoC Creator 4:

Active Protocol - JTAG

Power - 3.3V

Clock Speed - 24MHz

Acquire Mode - Reset

When I click Port Acquire, the error message I receive is "There was an error running port acquire: Can not acquire SWD device!".

Setting in PSoC Programmer:

Programming Mode : Reset

Verification : On

Auto Detection : On

Connector : 10p

Clock Speed : 24 MHz

Protocol : JTAG

Voltage : 3.3V

MiniProg3 is detected succesfully.

But I get the error message as "Device isn't powered! Apply power to target board to acquire it in "Reset" mode!".

What could it be that I am doing wrong? This is my first time I am using MiniProg3. Please do help me. I have been stuck with this for a few days now.

Thanks in advance. 

Magnus Lundin's picture
User
41 posts

Perhaps the error message is correct, and you have not supplied power to the board with the CY8C5868AXI-LP035.

vijayr.acns_1628096's picture
User
35 posts

Thank you Magnus for your reply. Won't the device be powered from the programmer itself? For that do I have to provide any additional settings?

ANKS's picture
Cypress Employee
345 posts

Go to (in PSoC Creator) to Tools>Options>Program/Debug>Port Configuration>MiniProg3 and select the power level (1.8V,5V,3.3V or 2.5V)to be given to the Board by MiniProg3

vijayr.acns_1628096's picture
User
35 posts

Hi Anks,

I had powered up the device. But I am still receiving the error "There was an error running port acquire: Can not acquire SWD device!". 

jobi's picture
Cypress Employee
103 posts

Hi,

Please make sure

#1 For Reset mode: PSoC Programmer Power is ON

#2 VDDD and VDDA pins are shorted. You need to use jumper wires.

Thanks

JOBIN

jobi's picture
Cypress Employee
103 posts

For JTAG protocol try decreasing the Clock speed to less than 3.2MHz

You might have noticed a warning saying the JTAG/SWD communication is not stable with the clock above 3.2MHz!

Jobin

Log in to post new comments.
RSS Back to Top
Topic locked