You are here

Programming my PSOC5 no longer possible with latest Programmer? | Cypress Semiconductor

Programming my PSOC5 no longer possible with latest Programmer?

Summary: 6 Replies, Latest post by epdi99 on 04 Sep 2012 03:14 PM PDT
Verified Answers: 0
Last post
Log in to post new comments.
user_189995688's picture
138 posts

With the latest PSoC Programmer I am now getting this error in both 'Programmer' and 'Creator 2.0'. The error reads:

Error: dbg.M0023: There was an error while programming the device: PSoC Programmer reported error (100 - FAILED! User NVLs update failed. This operation can be completed in voltage range 1.8 - 3.3 V only.)

I have always had my programmer set to 5.0V in the past with no problems at all and have hundreds of devices programmed this way. Is this a new requirement or some kind of bug? My device is a PSoC5 CY8C5588AXI-060.

My hardware design has all IO blocks at 5V and I'm not sure the board will be happy being programmed at 3v3. It also means that I cannot program the board when it is self powered. 


I really need to be able to retain the 5V setting which has worked perfectly for me till now, is there a rules file somewhere I can change? 

srim's picture
Cypress Employee
111 posts

 Can you provide the programmer build number that you are using? 

user_189995688's picture
138 posts



The build number is

Many thanks.

kabhijit's picture
32 posts

Hi all,

I am using the CY-8Kit with PSoC5 (ES-1). I got the same error, so I changed the power supply yo 3.3 V (using switch SW3) and the programmed it - it worked. Since then I can program the chip at 5V. Also verified that for all the CY8Kit-001 boards we have, I need to do 3.3V programming _once_  - then it works at 5V.

For the custom boards we have, there is a fixed 5V power supply - so am in a fix as to what to do with those. Can someone please say how to avoid programming the NVL's?




kabhijit's picture
32 posts

What i mentioned above is all done with PSoC Creator 2. I have PSoC creator 1 and 2 installed side-by-side, and PSoC programmer I cant say what version programmer is being used internally by PSoC Creator2.

~k Abhijit

vvsk's picture
Cypress Employee
25 posts

Hi Abhijit,

It was found that the endurance of the user NVL's in PSoC 5 silicon had a dependency on the device operating voltage and the desired voltage range was found to be 1.8 - 3.3 V. So the decision was made that in the production silicon of the PSOC 5 devices, we would not do programming of the user NVL's and have them at the default set of values. All the new PSOC 5 samples have the default nvl settings as we wanted to. But the devices already out on the field with customers might have a different NVL setting than the default setting. So PSOC programmer tries to restore the values to the default value while programming these devices the first time. And for this one time programming, it expects the 1.8-3.3 V operating voltage. But once you have programmed with the default values, the next tries of programming will not need a NVL  programming and hence there is no need for the 3.3V restriction.

The bottomlime is,

Existing PSOC 5 samples (with ES1 marking on them) already in use by customers will require a 3.3 V programming once to restore th NVL's to the default value in case they have different values.

Production PSoC 5 samples (no ES1 marking on them) have no restriction on the Vddd voltage during programming as they already have the correct default values.

None of the PSoC 3 samples (new or old) have NVL programming limitations. They support NVL programming across all device operating voltages.



epdi99's picture
1 post

Just now converting from ES1 silicon to production silicon. I had a different experience than that described above. The production silicon programmed once at 5V, but gave the "User NVLs updated failed." error for any subsequent programming attempts. I suspect I didn't run into this issue until now because we've been mounting the development kit directly to our board. I had no problems with it.

I programmed at 3.3V successfully and am able to program at 5V after that. An ok fix, but it requires removal of a 5V watchdog chip. Obviously, not a workable solution.

Anyone have any ideas?


Log in to post new comments.