You are here

JTAG, XRES, PROGRAMING | Cypress Semiconductor


Summary: 2 Replies, Latest post by alex934 on 30 Jul 2015 07:14 AM PDT
Verified Answers: 1
Last post
Log in to post new comments.
alex934's picture
37 posts

Hi everyone,

I'm working with a CY8C5888LTI-LP097  (PSOC5LP).

I'm want to program it with JTAG so I connected the 10 pins as my attachment. I use the [1.2] (pin13) XRES instead of  pin10 but I can connect it with a strap if needed.

Now my problem is that when I connected JTAG from miniprog 3 with the parameters in attachment when I try to upload the program, the target doesn't appear, I have to clic on Port Acquire, and after 30second, it appears with a second target where it is write :"(Test Controller)" as you can see on attachment. And finally i can program the PSOC.


Why my target doesn't appear directly?!? 

I tryed to enable the "Use Optional XRES" but its doesn't work better...

Should I use PullUp on Xres or Not?

When I try to program it with SWD( 10pin) the target is directly find but the programming doesn't work.



Thank you very much, I read lot of topic and subjects and I still confuse about using XRES...

user_14586677's picture
7646 posts

Have you seen this -


Also followed the recommendations for bypassing in the datasheet ?


Regards, Dana.

alex934's picture
37 posts

Well, yes I did.

I connected each capacitance and JTAG close to the µC, the VCCD is connected with a short trace...
The only difference with the example and my schematic is that they put 1µF on Vddd and Vdda, It can be the problem?


Thank you

Log in to post new comments.