You are here

CY8C5588AXI-060 UNASSIGNED: The selected debug target is not compatible with the project's selected device | Cypress Semiconductor

CY8C5588AXI-060 UNASSIGNED: The selected debug target is not compatible with the project's selected device

Summary: 7 Replies, Latest post by Bob Marlowe on 15 Feb 2016 01:56 AM PST
Verified Answers: 0
Last post
Log in to post new comments.
user_45458497's picture
2 posts


I'm triing to programm a new PSOC5 module for the first time. The Layout is copied from an other working project but still I can't programm the device.

In PSOC Programmer the device is shown in the JTAG chain (0E13C069), but the checksum can't be read nor any other reading operation is performed correctly.


In PSOC Creator following error is displayed:

dbg.M0033: The selected debug target 'CY8C5588AXI-060 UNASSIGNED' is not compatible with the project's selected device 'CY8C5588AXI-060 ES1'.

(Programming of the cypress demo board works flawless, although it's exactly the same device.)


How can I resolve this problem?

I don't think it's

 because of the copied layout...


dasg's picture
Cypress Employee
730 posts

Hi cidex,


This is the reason sighted for getting the error message which you are seeing in PSoC Creator documentation.

"The target device selected in this window does not have a Silicon ID and Revision that matches the current project's selected device. Either pick a different debug target here, or go back and change the project's selected device. If you believe the target's detected revision number is incorrect, verify that the selected Debug Clock is 1/3 of the chip's Bus Clock and try running Port Acquire to reset the device."

To select the correct device,

Right click on the project in the workspace > Device Selector > Select the right device

Are you using CY8CKIT-001 or CY8CKIT-0050? And which programming mode are you using, JTAG or SWD?






Pablo345's picture
1 post

Hallo dasg,

i have the same problem that the PSOC 5 can't be detected. It shows the same warning as above described.

I tried to follow your instructions which also appeared in the PSOC Creator screen.

But it didn't work. So i reselected the PSoc5 via the the debug selector and also tried to change the frequency of

the debug clock to 1/3 o f the bus clock and other frequencies.

What happened with the problem of cidex. Were you able to help him?

Can u please help me.

Best regards,





please read this ..

Source: Cypress

-Makarand Krishna Patil

spruce's picture
2 posts

My creation started to do this today. I finally found that the VDDDio1 had lost the connection to VDDD. hope this helps. I also found that the supply power to the miniprog pin should come from this pin as well. The id of the silicon is now rock solid.

uday's picture
Cypress Employee
569 posts

 Spruce, which kit are you using ?

Karthikeyan S's picture
4 posts

Is the problem solved ? I am facing this issue. "Error: dbg.M0033: The selected debug target 'CY8C5888LTI-LP097' is not compatible with the project's selected device 'CY8C5868AXI-LP035'."

What was the solution

user_1377889's picture
9279 posts

What was the solution?

Creator -> Project -> Device Selector  and there choose the CY8C5888LTI-LP097.  Some adjustments might be needed, check for messages.



Log in to post new comments.