You are here

Timer_writePeriod() API call not working | Cypress Semiconductor

Timer_writePeriod() API call not working

Summary: 1 Reply, Latest post by Bob Marlowe on 30 Dec 2015 02:05 AM PST
Verified Answers: 0
Last post
Log in to post new comments.
bhargavi_eie_1555876's picture
2 posts


I built a simple timer example with terminal count ISR enabled.

I tried setting the Peroid through Timer_writePeriod() API call. but it always takes period from the configuration window.

Tried manually forcing counter to zero  through Timer_writeCounter(0) API call but this triggers tc interrupt immediately.

I have attached my code.


Thanks in advance.




user_1377889's picture
9296 posts

I cannot believe that you wait 2 hours for the timer to expire :-)

Datasheet says for WritePeriod() that the new period is used the next time the timer is reloaded. so what you observe is as it should be.

Setting the counter to zero has to fire tc interrupt immediately.

Workaround: use a reset input which you may connect to a control register



Log in to post new comments.