You are here

Second custom characeristic in Custom Service not showing | Cypress Semiconductor

Second custom characeristic in Custom Service not showing

Summary: 2 Replies, Latest post by r.dijkstra05_1488816 on 18 Oct 2016 08:27 AM PDT
Verified Answers: 1
Last post
Log in to post new comments.
r.dijkstra05_1488816's picture
User
6 posts

Hello,

I have created a custom service on the BLE profile, which should hold multiple characteristics.

After I created the first characteristic, everything is working just fine, service and characteristic are showing in CySmart and my 'self built' android app.

However, when I add a second characteristic or service (in the same way as I did with the first characteristic or service) this second characteristic or service is not showing.

I tried both adding a second custom characteristic to the custom service and adding a second custom service with it's own custom characteristic.

Can anyone please help me out on what I'm missing? Problem may be in the UUID's, but if so, I wouldn't know which rules to follow to fix it.

I have attached a screenshot of my profile, I am using the following UUID's;

Service - Milivolts -            00000000-0000-1000-8000-00805F9B34F0
  Characteristic mVmeten - 00000000-0000-1000-8000-00805F9B34F1
    Custom Descriptor -        00000000-0000-1000-8000-00805F9B34F2

Service - MiliAmpere -       00000000-0000-1000-8000-00805F9B34F3
  Custom Characteristic-     00000000-0000-1000-8000-00805F9B34F4
    Custom Descriptor -        00000000-0000-1000-8000-00805F9B34F5

Any support would be much appreciated

 

 

Anjana Muralidharan's picture
Cypress Employee
61 posts

Hello,

Can you please try changing the UUID base?

When you create a custom service, the automatically generated UUID will be in the bluetooth base UUID. For higher versions of Android (5.0 and above) does not allow access to custom UUIDs which use the same base UUID as the bluetooth base UUID. The user has to update/modify the default base UUID with a different base UUID.

Please refer our appnote:  http://www.cypress.com/documentation/application-notes/an91162-creating-...

Pg: 8, section 4.4 Generate Custom UUID.

Let us know if it helps.

Thanks,
Anjana

r.dijkstra05_1488816's picture
User
6 posts

Hello,

I tried several UUID's but nothing worked. This untill my PSOC froze and I had to power it down/up again. After that all added characteristics were visible (?)

After some testing I found that the CySmart app does not automatically show updated or changed bluetooth profiles. In the menu (top right of the app screen) there is a checkbox available with the option 'Clear Cache on disconnect'. Checking this option solved a lot of my unexplaine behaviour. From this point on, all updates I make on the PSOC are actually visible in the CySmart app!

So far, the UUID's in my first post seem to work fine, even with more than one custom characteristics added to my custom server.

Log in to post new comments.