You are here

Pairing problem with CY8CKIT-042-BLE | Cypress Semiconductor

Pairing problem with CY8CKIT-042-BLE

Summary: 3 Replies, Latest post by VAVC on 27 May 2015 06:42 PM PDT
Verified Answers: 0
Last post
Log in to post new comments.
Raghavg's picture
2 posts


We have tried paring in two scenarios but seems CY8CKIT-042-BLE doesnot support pairing:

1. With Nexus5 ( android Lollipop) - We get a response saying that the device rejected pairing.


2. With our custom BLE controller - We get a pairing response with error code " Pairing not supported (0x05)"


Could you please confirm whether the " CY8CKIT-042-BLE Bluetooth® Low Energy (BLE) Pioneer Kit" supports BLE pairing.  Currently we are using the Advertisement enable switch to the make the device discoverable and once it is discovered, we are trying to pair with the device. In case the device support BLE pairing, could you please let us know the steps that need to be followed to pair it with any standard device( say Nexus 5).



We would like to know if pairing is supported on this platform as we get a message indicating Pairing not supported, which would mean LE ping/Privacy will not be supported as well.

Is there a separate procedure/switch to enable pairing?


Please confirm. Have anyone observed this problem?



user_1377889's picture
9241 posts

Welcome in the forum!

Cypress PSoC BLE and PRoC BLE both support pairing.

See this project and this one.



user_78878863's picture
2546 posts

Look at the GAP setting of the BLE component. Go to 'security' in the left-side tree, and set the security level to support pairing.

Also, read the data sheet, it explains how all the options work together.

VAVC's picture
Cypress Employee
506 posts



If you just use the kit out of box, it won't support pairing.Beacuse by default the kits comes with project PSoC_4_BLE_CapSense_Slider_LED which is available in the path "C:\Program Files (x86)\Cypress\CY8CKIT-042-BLE Kit\1.0\Firmware\PSoC 4 BLE\PSoC_4_BLE_CapSense_Slider_LED\PSoC_4_BLE_CapSense_Slider_LED.cydsn". As this project doesn't support pairing that's why you might be getting that error.




Log in to post new comments.