You are here

Liquid Level Sensing Code on CY8CKIT-042-BLE Kit | Cypress Semiconductor

Liquid Level Sensing Code on CY8CKIT-042-BLE Kit

Summary: 3 Replies, Latest post by kevin.abas_1891411 on 20 Oct 2016 10:06 AM PDT
Verified Answers: 1
Last post
Log in to post new comments.
paulcreaser_1517661's picture
5 posts

My company recently purchased a CY8CKIT-042-BLE Bluetooth® Low Energy (BLE) Pioneer Kit and CY8CKIT-022 CapSense® Liquid Level Sensing Shield in the hope of using them together. We downloaded the PSOC creator and the PSOC programmer and updated the CY8CKIT-042-BLE KitProg firmware.

We then downloaded the Liquid Level Sensing code example from However on attempting to program the device (LLS_CSD_12RX-042.hex) it reported the hex device didn't match the device we wished to program so it couldn't program it.

There are a number of possibilities, I guess.

  1. Change the device name and recompile the code
  2. Use a CY8CKIT-042 Kit (without BLE)

I have a CY8CKIT-042, which I can test tomorrow, however I would prefer to use the CY8CKIT-042-BLE kit.



user_1377889's picture
9274 posts

Welcome in the forum, Paul.

In Creator -> Project -> Device Selector you may specify which PSoC chip you want the project to be built for. When changing the device some GPIO pins may not fit, check that. Additionally check the pins with the schematic, some of them are in use by I2C or bypass capacitors. Schematics you find under Programs(x86)\Cypress\ , there all your successfully installed kits are listed.



paulcreaser_1517661's picture
5 posts

Thank you, just as I thought. I will look to modify the code so it matches the chip GPIO mappings.

I happen to also have a CY8CKIT-042, so I tried that out this morning. I was able to successfully flash that Kit with the example Liquid Sense code, however the reading over the serial line, always indicate the bottle is full of water, regardless of being empty or any other state.

After calibrating for an empty bottle it worked perfectly.

kevin.abas_1891411's picture
1 post

I'm having issues using the kit with CY8CKIT-042-BLE as well, the pin mapping are clear for the BLE kit and I've checked to make sure they are indeed connected to the ones the liquid board has printed on it for the BLE kit. (Only RX12, seems to be disconnected, and I don't have an option to map CintA or CintB or TX0 in the project)

I even see the valid uart prints and can use uC Probe. It starts out full as in the demo and I can calibrate it to zero, but then is remains there. All I seem to be able to change on the Micrium interface is the sensor limit which has no effect.

Is there a way to increase sensitivity or boost the sensor signals in some way? I will look further into the project, but I was hoping for plug and play :)

Log in to post new comments.