You are here

How to limit BLE component to 4.0 only ? | Cypress Semiconductor

How to limit BLE component to 4.0 only ?

Summary: 7 Replies, Latest post by chaplin.u_1533771 on 28 Nov 2016 02:57 AM PST
Verified Answers: 1
Last post
Log in to post new comments.
chaplin.u_1533771's picture
User
105 posts

I found that some of devices that have Bluetooth 4.0 can`t discover or can`t connect to my device but new devices can.

How to limit BLE component to 4.0 only ? 

HIMA's picture
Cypress Employee
205 posts

Hello

Can you please tell more details of the device. Please give the exact part number.

Thanks,

Hima

chaplin.u_1533771's picture
User
105 posts

It`s not only one device and see other messages about this issue. This  exist in Android. Because exist many versions on market I can compile with SDK to lowest version that I need. Same way Cypress must provide BLE component that can work with lowest ( 4.0)  version of BLE. May be some variable for compiler #ifdef BLE_4_0 ...

chaplin.u_1533771's picture
User
105 posts

Why nobody answer ? Any Cypress employers saw it ? Problem exist but nobody care about ???

 

mady's picture
Cypress Employee
967 posts

Hi,

Can you please ensure that the devices that have Bluetooth 4.0 have BLE also in addition to classic bluetooth. Bluetooth 4.0 does not guarantee that BLE is also present. Our devices can be discovered only by devices that support BLE.

Regards,

-Madhu

chaplin.u_1533771's picture
User
105 posts

Hi !

Please pay attention that I talk not about some device that have a problem. I asked about BLE component in PSOC Creator.

You provide it with last version 4.2 but many devices have only 4.0 or 4.1 drivers. Do you have back compatibility to old versions ?

I think must be possibility  to limit code to versions of BLE.

BTW very soon BLE 5 going to arrive...

 

yssu's picture
Cypress Employee
20 posts

Hi Chaplin,

A Bluetooth 4.2 device can communicate with a Bluetooth 4.1 and 4.0 device(back compatible) provided that the 4.2 device does not use any Bluetooth 4.2 features.

In PSoC Creator, you can use BLE component(v3.1 and v3.2) which are Bluetooth 4.2 compatible, i.e they support the 4.2 features. 

Say you have a CYBLE-222005-00, which is a 4.1 device. Now, you can still use BLE component v3.1 and v3.2. PSoC Creator knows that CYBLE-222005-00 is a 4.1 device and will return an error(and sometimes will not allow) if you try to use 4.2 features. 

However if you want to restrict to Bluetooth 4.1, you will have to use older version of BLE Component, version v2.30. It is not recommended to use a older version because later versions have bug fixes and advanced features. To change version of component, right-click on project, select 'Update Components...', select v2.3 under BLE.

chaplin.u_1533771's picture
User
105 posts

Thanks, I`l try but as you said in new version was bug fixes and I`l receive it ... 

It must be done in component or by variable. As I said very soon you will create BLE5 component and this issue will be VERY actual.

Log in to post new comments.