You are here

Dongle Firmware Version | Cypress Semiconductor

Dongle Firmware Version

Summary: 7 Replies, Latest post by Alec Schmidt on 13 Jul 2015 09:33 AM PDT
Verified Answers: 0
Last post
Log in to post new comments.
Stub for 461613992's picture
1 post


I am using CySmart version 1.0 (from the Dec 31 download).

I am connecting to a BLE dongle from the  CY8CKIT.


CySmart refuses to connect to the dongle, and instead say it needs to be updated with the firmware from

C:\Program Files (x86)\Cypress\CY8CKIT-042-BLE Kit\1.0\Firmware\BLE Dongle\Hex Files\BLE_Dongle_CySmart.hex


I have used the PSoC Programmer version  3.22.0  and reprogrammed the dongle with this hex file.


I have also downloaded the Dec 31 hex file version  from here  and programmed that hex.


Niether of these hex files have changed CySmart's mind, it still says the current firmware is not supported.


Can someone please confirm that the latest version of CySmart is valid, and the dongle hex file is valid?

I can find no other options for making this work. 

Thank you




Clumsy's picture
Cypress Employee
2 posts

 Have you updated the FW on the BLE part via the Update Firmware button the Utilities tab?  

There are two parts on the dongle and each may require a FW update.  The PSoC 5LP USB bridge is updated by programming the hex file as you described.  The BLE part is udpate by connected to the dongle in PSoC Programmer, going to the Utilities tab and selecting Udpate Firmware.

user_14586677's picture
7646 posts

If you face any issues, with CySmart in recognizing the dongle, please do the following steps:


a)      Upgrade the KitProg (PSoC 5LP) firmware in the dongle. (Please check Page 39 of:

b)      Now Program the latest BLE Dongle CySmart hex to the PRoC device (available for download from :


Regards, Dana.


WOFR's picture
1 post

I had the same problem. Dana's explanation above solved it for me. Thanks!

AKL's picture
10 posts

 I had the same problem, but Dana's steps solved it. Thanks Dana for the direct & simple steps. However, it didn't work from the first time, so i did the following:

1- From Control pannel>Device manager, i disabled any device that is using the COM port to illiminate conflict posibilities

2- Restart your PC

3- Apply Dana's steps

it should work now

user_490131959's picture
31 posts

I tried all the suggestions here, however, I have not had any luck getting past this problem.

Any other suggestions please?



gul's picture
Cypress Employee
44 posts

Hi David,

Updating the CySmart dongle is a 2-step process

1. Step #1 is to update the KitProg firmware on the dongle (the programmer firmware).
You can do this by opening the latest version of PSoC Programmer, and then under the Utilities tab you will find a button to update firmware.

2. Step#2 is to update the firmware of the PRoC BLE device on the dongle.
You can do this by loading the required HEX file in PSoC Programmer, then hitting the Program button to update the PRoC BLE device on the dongle.


Please ensure you have the latest kit files from the website:


hope that helps!


Alec Schmidt's picture
7 posts

Another engineer and I both had issues with the dongle that came in each of our kits as well.  I wrote up some instructions with screenshots that could help fix the issue, you can find them at


I hope the link helps, best of luck.

Log in to post new comments.