You are here

PSOC 4 CY8CKIT-049 kit, Bootloader reported error 'Packet Length invalid' | Cypress Semiconductor

PSOC 4 CY8CKIT-049 kit, Bootloader reported error 'Packet Length invalid'

Summary: 4 Replies, Latest post by Danyi on 12 Oct 2016 05:35 AM PDT
Verified Answers: 0
Last post
Log in to post new comments.
royarchana44_1805711's picture
User
2 posts

I am new to PSoC and using  PSoC4 CY8CKIT-049 kit. I tested it with LED blink program and its working fine. Now I tried to see result for ADC but I am getting error- Bootloader reported error 'Packet data invalid': The packet sent to the bootloader does not conform to the required packet format.

The program I wrote is a simple one. Programm inside for loop is:

aVal  = ADC_GetResult16(0);

LED_Write(!LED_Read());

if(aVal> 2047) aVal = 2047;

if(aVal<1) aVal = 1;

aVal == aVal/2 +100;

CyDelay(aVal);

 

user_1377889's picture
User
9608 posts

Welcome in the forum!

This error is not related to the program you have written, it is a matter of communications between your bootloader which is already programmed into your kit and which cannot be overwritten.

Check the bootloadable component for the correct path to your original bootloader .hex and .elf files.

Check the baud rate settings

Triple check whether you took the correct com port

Check for the right blinking mode when kit was inserted with switched pressed.

 

Bob

royarchana44_1805711's picture
User
2 posts

I have checked again and again, but unable to find any error. Now when I am running my led blink program, it is showing the same error, but still the led is blinking. Not getting what is going wrong.

user_1377889's picture
User
9608 posts

Can you please post your complete project, so that we all can have a look at all of your settings. To do so, use
Creator->File->Create Workspace Bundle (minimal)
and attach the resulting file.

 

Bob

Danyi's picture
User
5 posts

Hi,

I have the same problem. After a working day with the kit, at the end the bootloader has sent me the same error, for all programs which had already worked .

Some additional info: I updated Psoc Creator to 4.0 and, also Cy_Boot to the last version together with the components according to Forum disscutions. The result is the same "Packet data invalid" for all my programs and for both kits. Should be a issue of  configuration.

 

CY8CKIT 049 4125 AXI 483 

CY8CKIT 049 4245 AXI 483

Please, give me an advice!

Thank You!

Log in to post new comments.