You are here

Problems with Hardware Connection - PSoC 4 Pioneer Kit | Cypress Semiconductor

Problems with Hardware Connection - PSoC 4 Pioneer Kit

Summary: 2 Replies, Latest post by heimo.gaicher_1629436 on 03 Nov 2016 04:02 AM PDT
Verified Answers: 1
Last post
Log in to post new comments.
gaicher_1912301's picture
User
3 posts

Hi,

I'm starting with the Pioneer Kit and want to use an easy HW-Connection to link the switch (P0_7) with the input of a counter to count down 3 button presses to switch on the red LED (P3_4).

Unfortunately i get an error when i check the HW connection on the digital input pin with the Drive Mode "Resistive pull up".

This is the error message:

Pin 0: Use of drive modes which are not High Impedance with a hardware-routed input requires a port adapter, but the selected device does not have one.

Can somebody explain, which is the meaning of this message?

user_1377889's picture
User
9572 posts

Too many possibilities, can you please post your complete project, so that we all can have a look at all of your settings. To do so, use
Creator->File->Create Workspace Bundle (minimal)
and attach the resulting file.

 

Bob

heimo.gaicher_1629436's picture
User
2 posts

Hi Bob,

in the meantime i found the answer:

Described on page 37  in the Pins datasheet --> Some devices, such as PSoC 4000 series do not have Port Adapters and this limits some pin features.

In this case i have to use my CY8CKIT-042-BLE to test it again.

 

 

Log in to post new comments.